Can you answer these queries?

版权声明:来自星空计算机团队——申屠志刚 https://blog.csdn.net/weixin_43272781/article/details/83443934

A lot of battleships of evil are arranged in a line before the battle. Our commander decides to use our secret weapon to eliminate the battleships. Each of the battleships can be marked a value of endurance. For every attack of our secret weapon, it could decrease the endurance of a consecutive part of battleships by make their endurance to the square root of it original value of endurance. During the series of attack of our secret weapon, the commander wants to evaluate the effect of the weapon, so he asks you for help. 
You are asked to answer the queries that the sum of the endurance of a consecutive part of the battleship line. 

Notice that the square root operation should be rounded down to integer.

Input

The input contains several test cases, terminated by EOF. 
  For each test case, the first line contains a single integer N, denoting there are N battleships of evil in a line. (1 <= N <= 100000) 
  The second line contains N integers Ei, indicating the endurance value of each battleship from the beginning of the line to the end. You can assume that the sum of all endurance value is less than 2 63. 
  The next line contains an integer M, denoting the number of actions and queries. (1 <= M <= 100000) 
  For the following M lines, each line contains three integers T, X and Y. The T=0 denoting the action of the secret weapon, which will decrease the endurance value of the battleships between the X-th and Y-th battleship, inclusive. The T=1 denoting the query of the commander which ask for the sum of the endurance value of the battleship between X-th and Y-th, inclusive. 

Output

For each test case, print the case number at the first line. Then print one line for each query. And remember follow a blank line after each test case.

Sample Input

10
1 2 3 4 5 6 7 8 9 10
5
0 1 10
1 1 10
1 1 5
0 5 8
1 4 8

Sample Output

Case #1:
19
7
6

题意:

给一个序列,有俩种操作,一种是求区间和,一种是将区间每个数开根号后向下取整。  就是一道线段数的题。
坑点:

1.注意:Case #1:有个冒号
2.数据是long long,如果是int会TLE,因为超出int,就是负数,你所有的优化都会失效。
3.注意输入和输出都要用%lld
4.最重要的是他给的区间l和r,l可能会大于r,那么就要先交换位置,最坑的一点,没有之一。

解题思路:

就是一个线段树,但是是开根号,没有办法用延迟更新,但是取根号在6,7次就会到1.
那么我们模拟区间更新,如果父节点的权值和r-l+1相等,那么就不用忘下更新了。因为都是1
具体看代码

#include <iostream>
#include <stdio.h>
#include <algorithm>
#include <string.h>
#include <math.h>
using namespace std;
int n,m;
long long tree[100010*4];
long long a[100000+10];
void PushUp(int rt){
    tree[rt] = tree[rt*2] + tree[rt*2+1]; ///区间和的更新操作
}

void Build(int l,int r,int rt){
    // l,r 代表的是这个区间内的左端点 和 右端点, rt代表的是 [l,r] 这个区间内的值是存在哪一个位置的。
    if(l==r){
        //scanf("%d",&tree[rt]);
         tree[rt] = a[l];
        return;
    }
    int m=(l+r)/2;// 对于区间区分,我们一般将m点划入左半边区间
    Build(l,m,rt*2);
    Build(m+1,r,rt*2+1);
    PushUp(rt); // PushUp 函数是通过2个子节点来更新现在这个节点的状态, 对于不同的要求需要不同的写法。

}
long long Query(int l,int r,int rt,int L,int R){// [L,R]为查询区间
    if(L<=l&&r<=R){
        return tree[rt];// 如果成立则满足查询区间覆盖了当前区间, 直接返回当前区间的值
    }
    int m=(l+r)/2;
    long long res=0;
    if(L<=m)    res+=Query(l,m,rt*2,L,R);//左边有一部分需要查询的区域。
    if(m<R)     res+=Query(m+1,r,rt*2+1,L,R);//右边有一部分。
    return res;

}
void Updata(int l,int r,int rt,int L,int R){// l,r,rt 与前面的定义一样, L代表的是要更新区间的位置,C代表的是修改后的值

    if(L<= l && r <= R && tree[rt] == (long long)(r-l+1))
    {
        return ;
    }
    if(l==r){// 这里不能写成 if(l == L) 因为有可能左端点恰好是要更新的位置, 但是还有右端点, 我们直接更新的只有区间 [L,L]。
        tree[rt]=(long long )sqrt(1.0*tree[rt]);
        return ;
    }
    int m=(l+r)/2;
    if(L<=m) Updata(l,m,rt*2,L,R);//要更新的区间在左边部分,所以往左边走,更新左边
    if(m<R) Updata(m+1,r,rt*2+1,L,R);//要更新的区间在右边部分, 往右边走,更新右边
    PushUp(rt);//更新完子节点之后需要更新现在的位置, 需要保证线段树的性质。
}
int main()
{

    int cnt=1;
    while(scanf("%d",&n)!=EOF){

        for(int i = 1; i <= n; i++)
            scanf("%lld", &a[i]);
        Build(1,n,1);
        int x,y,t;
        printf("Case #%d:\n",cnt++);
        scanf("%d", &m);
        while(m--){

            scanf("%d%d%d",&t,&x,&y);
            if(x>y){
                int temp=x;
                x=y;
                y=temp;
            }
            if(t==0){

                    Updata(1,n,1,x,y);
            }
            if(t==1){
                cout << Query(1,n,1,x,y) << endl;
            }

        }
        cout << endl;
    }
    //cout << "Hello world!" << endl;
    return 0;
}


 

猜你喜欢

转载自blog.csdn.net/weixin_43272781/article/details/83443934