hdu 4027 Can you answer these queries? —— 线段树

Problem Description
A lot of battleships of evil are arranged in a line before the battle. Our commander decides to use our secret weapon to eliminate the battleships. Each of the battleships can be marked a value of endurance. For every attack of our secret weapon, it could decrease the endurance of a consecutive part of battleships by make their endurance to the square root of it original value of endurance. During the series of attack of our secret weapon, the commander wants to evaluate the effect of the weapon, so he asks you for help.
You are asked to answer the queries that the sum of the endurance of a consecutive part of the battleship line.

Notice that the square root operation should be rounded down to integer.

Input
The input contains several test cases, terminated by EOF.
For each test case, the first line contains a single integer N, denoting there are N battleships of evil in a line. (1 <= N <= 100000)
The second line contains N integers Ei, indicating the endurance value of each battleship from the beginning of the line to the end. You can assume that the sum of all endurance value is less than 263.
The next line contains an integer M, denoting the number of actions and queries. (1 <= M <= 100000)
For the following M lines, each line contains three integers T, X and Y. The T=0 denoting the action of the secret weapon, which will decrease the endurance value of the battleships between the X-th and Y-th battleship, inclusive. The T=1 denoting the query of the commander which ask for the sum of the endurance value of the battleship between X-th and Y-th, inclusive.

Output
For each test case, print the case number at the first line. Then print one line for each query. And remember follow a blank line after each test case.

Sample Input
10
1 2 3 4 5 6 7 8 9 10
5
0 1 10
1 1 10
1 1 5
0 5 8
1 4 8

Sample Output
Case #1:
19
7
6

题意:n个数,m次操作,op,x,y。op=0的时候表示a[i]= a [ i ] min(x,y)<=i<=max(x,y)
op=1的时候对min(x,y)到max(x,y)区间内求和
看到坑点了吗,他的x不一定小于y,呵呵
题解:
因为所有数的和都不超过 2 63 那么就算单点更新,每个点也不会超过10次,用一个maxn数组记录是否需要更新。一个区间的最大值是1的时候就代表不需要

#include<bits/stdc++.h>
using namespace std;
#define ll long long
#define eps 1e-5
const int N=1e5+5;
ll sum[N*4],maxn[N*4],a[N];
void pushup(int root)
{
    sum[root]=sum[root<<1]+sum[root<<1|1];
    maxn[root]=max(maxn[root<<1],maxn[root<<1|1]);
}
void build(int l,int r,int root)
{
    if(l==r)
    {
        sum[root]=maxn[root]=a[l];
        return ;
    }
    int mid=l+r>>1;
    build(l,mid,root<<1);
    build(mid+1,r,root<<1|1);
    pushup(root);
}
void update(int l,int r,int root,int ql,int qr)
{
    if(maxn[root]==1)
        return ;
    if(l==r)
    {
        sum[root]=sqrt(sum[root])+eps;
        maxn[root]=sum[root];
        return ;
    }
    int mid=l+r>>1;
    if(mid>=ql)
        update(l,mid,root<<1,ql,qr);
    if(mid<qr)
        update(mid+1,r,root<<1|1,ql,qr);
    pushup(root);
}
ll query(int l,int r,int root,int ql,int qr)
{
    if(l>=ql&&r<=qr)
        return sum[root];
    ll ans=0;
    int mid=l+r>>1;
    if(mid>=ql)
        ans+=query(l,mid,root<<1,ql,qr);
    if(mid<qr)
        ans+=query(mid+1,r,root<<1|1,ql,qr);
    return ans;
}
int main()
{
    int n;
    int cas=0;
    while(~scanf("%d",&n))
    {
        memset(sum,0,sizeof(sum));
        memset(maxn,0,sizeof(maxn));
        for(int i=1;i<=n;i++)
            scanf("%lld",&a[i]);
        build(1,n,1);
        int m;
        scanf("%d",&m);
        printf("Case #%d:\n",++cas);
        int op,l,r;
        for(int i=1;i<=m;i++)
        {
            scanf("%d%d%d",&op,&l,&r);
            if(l>r)
                swap(l,r);
            if(op==0)
                update(1,n,1,l,r);
            else
                printf("%lld\n",query(1,n,1,l,r));
        }
        printf("\n");
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/tianyizhicheng/article/details/82710929