poj 1981 Circle and Points

Circle and Points
Time Limit: 5000MS   Memory Limit: 30000K
Total Submissions: 8374   Accepted: 2991
Case Time Limit: 2000MS

Description

You are given N points in the xy-plane. You have a circle of radius one and move it on the xy-plane, so as to enclose as many of the points as possible. Find how many points can be simultaneously enclosed at the maximum. A point is considered enclosed by a circle when it is inside or on the circle. 
 
Fig 1. Circle and Points

Input

The input consists of a series of data sets, followed by a single line only containing a single character '0', which indicates the end of the input. Each data set begins with a line containing an integer N, which indicates the number of points in the data set. It is followed by N lines describing the coordinates of the points. Each of the N lines has two decimal fractions X and Y, describing the x- and y-coordinates of a point, respectively. They are given with five digits after the decimal point. 

You may assume 1 <= N <= 300, 0.0 <= X <= 10.0, and 0.0 <= Y <= 10.0. No two points are closer than 0.0001. No two points in a data set are approximately at a distance of 2.0. More precisely, for any two points in a data set, the distance d between the two never satisfies 1.9999 <= d <= 2.0001. Finally, no three points in a data set are simultaneously very close to a single circle of radius one. More precisely, let P1, P2, and P3 be any three points in a data set, and d1, d2, and d3 the distances from an arbitrarily selected point in the xy-plane to each of them respectively. Then it never simultaneously holds that 0.9999 <= di <= 1.0001 (i = 1, 2, 3). 

Output

For each data set, print a single line containing the maximum number of points in the data set that can be simultaneously enclosed by a circle of radius one. No other characters including leading and trailing spaces should be printed.

Sample Input

3
6.47634 7.69628
5.16828 4.79915
6.69533 6.20378
6
7.15296 4.08328
6.50827 2.69466
5.91219 3.86661
5.29853 4.16097
6.10838 3.46039
6.34060 2.41599
8
7.90650 4.01746
4.10998 4.18354
4.67289 4.01887
6.33885 4.28388
4.98106 3.82728
5.12379 5.16473
7.84664 4.67693
4.02776 3.87990
20
6.65128 5.47490
6.42743 6.26189
6.35864 4.61611
6.59020 4.54228
4.43967 5.70059
4.38226 5.70536
5.50755 6.18163
7.41971 6.13668
6.71936 3.04496
5.61832 4.23857
5.99424 4.29328
5.60961 4.32998
6.82242 5.79683
5.44693 3.82724
6.70906 3.65736
7.89087 5.68000
6.23300 4.59530
5.92401 4.92329
6.24168 3.81389
6.22671 3.62210
0

Sample Output

2
5
5
11

Source

Japan 2004 Domestic

N个点的坐标,问单位圆最多可以覆盖多少点?

朴素做法,找到两个点的单位圆,枚举剩余点在不在圆内,时间复杂度O(n^3),快超时了;

//朴素枚举做法 
#include<cstdio>  
#include<cstdlib>  
#include<cstring>  
#include<cmath>  
#include<algorithm>  
#define eps 1e-8  
using namespace std;  
struct point{  
    double x,y;  
}A[310];  
double dist(point a,point b){  
    return sqrt((a.x-b.x)*(a.x-b.x)+(a.y-b.y)*(a.y-b.y));  
}  
void getmid(point p1,point p2,point ¢er){//计算圆心坐标画图即可看出  
    point mid;  
    mid.x=(p1.x+p2.x)/2.0;mid.y=(p1.y+p2.y)/2.0;  
    double angle=atan2(p1.x-p2.x,p2.y-p1.y); //反正切函数的弧度 
    double dcm=sqrt(1-dist(p1,mid)*dist(p1,mid));  
    center.x=mid.x+dcm*cos(angle);center.y=mid.y+dcm*sin(angle);  
}  
int main()  
{  
    int n,i,j,k;  
    while(scanf("%d",&n),n){  
        for(i=0;i<n;++i){  
            scanf("%lf%lf",&A[i].x,&A[i].y);  
        }  
        int ans=1;  
        for(i=0;i<n;++i){  
            for(j=i+1;j<n;++j){  
                if(dist(A[i],A[j])>2.0)continue;  
                point center;  
                getmid(A[i],A[j],center);  
                int cnt=0;  
                for(k=0;k<n;++k){  
                    if(dist(A[k],center)<1.0+eps)cnt++;  
                }  
                ans=max(ans,cnt);   
            }  
        }  
        printf("%d\n",ans);  
    }  
    return 0;  
}   

大神做法:

3.6与平面和空间打交道的计算几何 

极限情况 

所谓极限情况就是单位圆上有两个点,稍微动一下就会损失一个点,覆盖点最多的圆一定有一个是这种圆(当然当N=1的时候是个例外)。朴素想法是先固定两个点,然后枚举其他的点是否在这两个点决定的两个圆内,朴素得掉渣我就不写了。

更快的算法是,先只固定一个点i,该点的单位圆与其他点j的单位圆相交,形成i圆上的一段弧,该弧被j圆覆盖。最终圆如果在该弧上,则一定能覆盖j点。那么问题归结于找出i圆上被覆盖次数最多的一段弧。

至于弧的表示,用两个极角表示,分别为起始和终止,类似于一个区间。枚举完其他点之后,得到N-1个区间。将其排序后,从前往后扫描,碰到起始计数+1,碰到终止计数-1,同时更新答案。

至于极角的求解,三角函数我全忘光了……查了查维基才记起来,如图:

其中,acos的定义如下:

atan2的定义如下:

附上本蒟蒻代码:
//极角排序做法
#include<stdio.h>
#include<algorithm>
#include<cmath>
using namespace std;

#define maxn 310
typedef double p_type;

struct point 
{
	p_type x,y;
	point(){}
	point(p_type x,p_type y) : x(x),y(y){}
}ps[maxn];

struct polarAngle
{
	p_type angle;
	bool flag;//起点或者终点 
	const bool operator<(const polarAngle &other) 
	{
		return angle<other.angle;
	}
}as[maxn];

inline p_type dist(const point &P,const point &Q)
{
	return sqrt((P.x-Q.x)*(P.x-Q.x)+(P.y-Q.y)*(P.y-Q.y));
}

inline int solve(const int& n,const p_type& r)
{
	int result=1;
	for(int i=0; i<n; ++i)
	{
		int m=0;
		double d;
		for(int j=0; j<n; ++j)
		{
			if(i!=j&&(d=dist(ps[i],ps[j]))<=2)
			{
				double phi=acos(d/2);
				double theta = atan2(ps[j].y-ps[i].y,ps[j].x-ps[i].x);
				as[m].angle=theta-phi,as[m++].flag=1;
				as[m].angle=theta+phi,as[m++].flag=0;
			}
		}
		sort(as,as+m);
		for(int sum=1,j=0;j<m;++j)
		{
			if(as[j].flag)
				++sum;
			else
			    --sum;
			result=max(result,sum);
		}
	}
	return result;
}
int main()
{
	int n;
	while(scanf("%d",&n),n)
	{
		for(int i=0;i<n;i++)
		{
			scanf("%lf%lf",&ps[i].x,&ps[i].y);
		}
		printf("%d\n",solve(n,1.0));
	}
	return 0;
}


猜你喜欢

转载自blog.csdn.net/qq_36914923/article/details/80164212