#1131. Subway Map【单源最短路 + Dijkstra】

原题链接

Problem Description:

In the big cities, the subway systems always look so complex to the visitors. To give you some sense, the following figure shows the map of Beijing subway. Now you are supposed to help people with your computer skills! Given the starting position of your user, your task is to find the quickest way to his/her destination.
在这里插入图片描述

Input Specification:

Each input file contains one test case. For each case, the first line contains a positive integer N N N ( ≤ 100 \leq 100 100), the number of subway lines. Then N N N lines follow, with the i i i-th ( i = 1 , ⋯   , N i=1,\cdots,N i=1,,N) line describes the i i i-th subway line in the format:

M M M S[1] S[2] … \ldots S[M]

where M M M ( ≤ 100 \leq 100 100) is the number of stops, and S [ i ] S[i] S[i]'s ( i = 1 , ⋯   , M i=1,\cdots,M i=1,,M) are the indices of the stations (the indices are 4-digit numbers from 0000 to 9999) along the line. It is guaranteed that the stations are given in the correct order – that is, the train travels between S [ i ] S[i] S[i] and S [ i + 1 ] S[i+1] S[i+1] ( i = 1 , ⋯   , M − 1 i=1,\cdots,M−1 i=1,,M1) without any stop.

Note: It is possible to have loops, but not self-loop (no train starts from S S S and stops at S S S without passing through another station). Each station interval belongs to a unique subway line. Although the lines may cross each other at some stations (so called “transfer stations”), no station can be the conjunction of more than 5 lines.

After the description of the subway, another positive integer K K K ( ≤ 10 \leq 10 10) is given. Then K K K lines follow, each gives a query from your user: the two indices as the starting station and the destination, respectively.

The following figure shows the sample map.
在这里插入图片描述
Note: It is guaranteed that all the stations are reachable, and all the queries consist of legal station numbers.

Output Specification:

For each query, first print in a line the minimum number of stops. Then you are supposed to show the optimal path in a friendly format as the following:

Take Line#X1 from S1 to S2.
Take Line#X2 from S2 to S3.
......

where X i i i's are the line numbers and S i i i's are the station indices. Note: Besides the starting and ending stations, only the transfer stations shall be printed.

If the quickest path is not unique, output the one with the minimum number of transfers, which is guaranteed to be unique.

Sample Input:

4
7 1001 3212 1003 1204 1005 1306 7797
9 9988 2333 1204 2006 2005 2004 2003 2302 2001
13 3011 3812 3013 3001 1306 3003 2333 3066 3212 3008 2302 3010 3011
4 6666 8432 4011 1306
3
3011 3013
6666 2001
2004 3001

Sample Output:

2
Take Line#3 from 3011 to 3013.
10
Take Line#4 from 6666 to 1306.
Take Line#3 from 1306 to 2302.
Take Line#2 from 2302 to 2001.
6
Take Line#2 from 2004 to 1204.
Take Line#1 from 1204 to 1306.
Take Line#3 from 1306 to 3001.

Problem Analysis:

普通的建图方式不太容易找到换乘之前的线路,我们采用以下建图方式建图:

将同一条线路上所有能够相互到达的站点都互相建立一条边,例如一条线路具有 4 4 4 个站点,我们需要建立 3 + 2 + 1 3 + 2 + 1 3+2+1 总共 6 6 6 条边。

那么最坏情况下,总共 100 100 100 条线路,每条线路最多 100 100 100 个站点,那么总共需要建立的边数(双向边)就是: 2 × 100 × ( 99 + 98 + … + 1 ) ≈ 1 0 6 2\times 100\times (99 + 98 + \ldots + 1) \approx 10^6 2×100×(99+98++1)106 条边。

而采用以上特殊的建图方式,就可以将题目要求的换乘次数最少这样一个约束转化成经过的边数最少。

由于边数过多,朴素 Dijkstra 复杂度过高,可以采用堆优化 Dijkstra 求解,计算量约为 6.6 × 1 0 6 6.6\times 10^6 6.6×106

众多细节见代码。

Code

#include <iostream>
#include <cstring>
#include <algorithm>
#include <queue>
#include <vector>

#define x first
#define y second

using namespace std;

typedef pair<int, int> PII;

const int N =  10010, M = 1000010;

int n;
int h[N], e[M], ne[M], line[M], w[M], idx; // line 表示边所在的线路
int dist[N], cnt[N], pre[N]; // 点数 cnt
int stops[N]; // 每条线路的点数
string  info[N]; // 记录走过的线路信息
bool st[N];

void add(int a, int b, int c, int id) // line[]存储这条边位于哪条线路上
{
    
    
    e[idx] = b, w[idx] = c, line[idx] = id, ne[idx] = h[a], h[a] = idx ++ ;
}

string get_number(int x) // 题目要求所有编号保留四位数字,不足四位补前导0
{
    
    
    char res[5];
    sprintf(res, "%04d", x);
    return res;
} 

void dijkstra(int start, int end)
{
    
    
    memset(dist, 0x3f, sizeof dist);
    memset(cnt, 0, sizeof cnt);
    memset(st, 0, sizeof st);
    
    priority_queue<PII, vector<PII>, greater<PII>> heap;
    heap.push({
    
    0, start});
    dist[start] = cnt[start] = 0;
    
    while (heap.size())
    {
    
    
        auto t = heap.top();
        heap.pop();
        
        int ver = t.y;  
        if (ver == end) break;
        if (st[ver]) continue;
        st[ver] = true;
        
        for (int i = h[ver]; ~i; i = ne[i])
        {
    
    
            int j = e[i];
            if (dist[j] > dist[ver] + w[i])
            {
    
    
                dist[j] = dist[ver] + w[i];
                cnt[j] = cnt[ver] + 1;
                pre[j] = ver;
                info[j] = "Take Line#" + to_string(line[i]) + 
                          " from " + get_number(ver) + " to " +
                          get_number(j) + ".";
                heap.push({
    
    dist[j], j});
            }
            else if (dist[j] == dist[ver] + w[i]) // 这里就不需要加到堆中了,因为Dijkstra要求只有距离更新了才能加入堆
            {
    
    
                if (cnt[j] > cnt[ver] + 1)
                {
    
    
                    cnt[j] = cnt[ver] + 1;
                    pre[j] = ver;
                    info[j] = "Take Line#" + to_string(line[i]) + 
                              " from " + get_number(ver) + " to " +
                              get_number(j) + ".";
                }
            }
        }
    }
    
    cout << dist[end] << endl;
    vector<string> path;
    
    for (int i = end; i != start; i = pre[i])
        path.push_back(info[i]);
        
    for (int i = path.size() - 1; i >= 0; i -- )
        cout << path[i] << endl;
}

int main()
{
    
    
    cin >> n;
    memset(h, -1, sizeof h);
    
    for (int i = 1; i <= n; i ++ )
    {
    
     
        int m;
        cin >> m;
        for (int j = 0; j < m; j ++ ) cin >> stops[j];
        for (int j = 0; j < m; j ++ )
            for (int k = 0; k < j; k ++ )
            {
    
    
                int length;
                if (stops[0] != stops[m - 1]) length = j - k;// 如果不是环路
                else length = min(j - k, m - 1 - j + k);
                add(stops[j], stops[k], length, i);
                add(stops[k], stops[j], length, i);
            }
    }
    
    int m;
    cin >> m;
    while (m -- )
    {
    
    
        int start, end;
        cin >> start >> end;
        dijkstra(start, end);
    }
    
    return 0;
}

猜你喜欢

转载自blog.csdn.net/geraltofrivia123/article/details/121053592