wareless network

An earthquake takes place in Southeast Asia. The ACM (Asia Cooperated Medical team) have set up a wireless network with the lap computers, but an unexpected aftershock attacked, all computers in the network were all broken. The computers are repaired one by one, and the network gradually began to work again. Because of the hardware restricts, each computer can only directly communicate with the computers that are not farther than d meters from it. But every computer can be regarded as the intermediary of the communication between two other computers, that is to say computer A and computer B can communicate if computer A and computer B can communicate directly or there is a computer C that can communicate with both A and B.

In the process of repairing the network, workers can take two kinds of operations at every moment, repairing a computer, or testing if two computers can communicate. Your job is to answer all the testing operations.
Input
The first line contains two integers N and d (1 <= N <= 1001, 0 <= d <= 20000). Here N is the number of computers, which are numbered from 1 to N, and D is the maximum distance two computers can communicate directly. In the next N lines, each contains two integers xi, yi (0 <= xi, yi <= 10000), which is the coordinate of N computers. From the (N+1)-th line to the end of input, there are operations, which are carried out one by one. Each line contains an operation in one of following two formats:
1. "O p" (1 <= p <= N), which means repairing computer p.
2. "S p q" (1 <= p, q <= N), which means testing whether computer p and q can communicate.

The input will not exceed 300000 lines.
Output
For each Testing operation, print "SUCCESS" if the two computers can communicate, or "FAIL" if not.
Sample Input
4 1
0 1
0 2
0 3
0 4
O 1
O 2
O 4
S 1 4
O 3
S 1 4
Sample Output
FAIL
SUCCESS


题意是前N行给出所有电脑的坐标,通过两种操作。判断两个电脑能否对话。

并查集:把能连接的都归在一个集合内。

#include <iostream>
#include <cstdio>
#include <cstdlib>
#include <cstring>
#include <algorithm>
#include <cmath>
using namespace std;
int N,d;
struct pos
{
    int x,y;
}s[1010];
int parent[1010];
bool dis(double x1,double y1,double x2,double y2)
{
    double p=sqrt((x1-x2)*(x1-x2)+(y1-y2)*(y1-y2));
    return p<=d?1:0;
}
int findparent(int a){
    int r=a;
    while(r!=parent[r]){
        r=parent[r];
    }
    return r;
}
void unions(int a,int b)
{
    int pa,pb;
    pa=findparent(a);
    pb=findparent(b);
    if(pa!=pb){
        parent[pa]=pb;
    }
    return ;
}
int main()
{
    memset(parent,0,sizeof(parent));
    scanf("%d %d",&N,&d);
    for(int i=1;i<=N;i++){
        scanf("%d %d",&s[i].x,&s[i].y);
    }
    char p;int m;
    while(scanf("%c",&p)!=EOF){
        if(p=='O'){
            scanf("%d",&m);
            parent[m]=m;
            for(int i=1;i<=N;i++){
                if(parent[i]&&dis(s[i].x,s[i].y,s[m].x,s[m].y)){
                    unions(i,m);
                }
            }
        }
        else if(p=='S'){
            int m1,m2;
            scanf("%d %d",&m1,&m2);
            if(findparent(m1)==findparent(m2)){
                printf("SUCCESS\n");
            }
            else printf("FAIL\n");
        }
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/sinat_40948489/article/details/80034042