Wireless Network

Description

An earthquake takes place in Southeast Asia. The ACM (Asia Cooperated Medical team) have set up a wireless network with the lap computers, but an unexpected aftershock attacked, all computers in the network were all broken. The computers are repaired one by one, and the network gradually began to work again. Because of the hardware restricts, each computer can only directly communicate with the computers that are not farther than d meters from it. But every computer can be regarded as the intermediary of the communication between two other computers, that is to say computer A and computer B can communicate if computer A and computer B can communicate directly or there is a computer C that can communicate with both A and B.

In the process of repairing the network, workers can take two kinds of operations at every moment, repairing a computer, or testing if two computers can communicate. Your job is to answer all the testing operations.

Input

The first line contains two integers N and d (1 <= N <= 1001, 0 <= d <= 20000). Here N is the number of computers, which are numbered from 1 to N, and D is the maximum distance two computers can communicate directly. In the next N lines, each contains two integers xi, yi (0 <= xi, yi <= 10000), which is the coordinate of N computers. From the (N+1)-th line to the end of input, there are operations, which are carried out one by one. Each line contains an operation in one of following two formats:
1. “O p” (1 <= p <= N), which means repairing computer p.
2. “S p q” (1 <= p, q <= N), which means testing whether computer p and q can communicate.

The input will not exceed 300000 lines.

Output

For each Testing operation, print “SUCCESS” if the two computers can communicate, or “FAIL” if not.

Sample Input

4 1
0 1
0 2
0 3
0 4
O 1
O 2
O 4
S 1 4
O 3
S 1 4

Sample Output

FAIL
SUCCESS

题目大意:有n台电脑,d表示两台电脑的最大通信距离,超过无法通信。然后是n台电脑的坐标。对n台电脑进行修复。O表示维修好,S表示测试这两台电脑能否进行通信。
思路:考察并查集。
对每次修好的电脑及已修好的电脑进行遍历,分析其两台电脑之间是否能进行通信,能通信进行合并。判断时,看其是否在同一个集合。

代码

#include<iostream>
#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
int d;
int use[1001];
struct node{
    int pre,x,y;
}m[1001];
/*int find(int x)
{
    return x==m[x].pre?x:find(m[x].pre);
}*/
int find(int x)
{
    if(x!=m[x].pre)
    {
        m[x].pre=find(m[x].pre);
    }
    return m[x].pre;
}
void join(node a,node b)
{
    int fx=find(a.pre);
    int fy=find(b.pre);
    if(fx!=fy)
    {
        if((a.x-b.x)*(a.x-b.x)+(a.y-b.y)*(a.y-b.y)<=d*d)
        {
            m[fy].pre=fx;
        }
    }
}
int main()
{
    int n,i;
    char h;//o  s 
    int p,q;
    scanf("%d %d",&n,&d);
    for(i=1;i<=n;i++)
        m[i].pre=i;
    memset(use,0,sizeof(use));
    for(i=1;i<=n;i++)
        scanf("%d %d",&m[i].x,&m[i].y);
    while(scanf("\n%c",&h)!=EOF)
    {
        if(h=='O') 
        {
            scanf("%d",&p);
            use[p]=1;
            for(i=1;i<=n;i++)
            {
                if(use[i]&&i!=p)
                    join(m[i],m[p]);
            }
        }
        else
        {
            scanf("%d %d",&p,&q);
            if(find(p)==find(q))
                printf("SUCCESS\n");
            else
                printf("FAIL\n");
        }
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/lshsgbb2333/article/details/80197558