Network Saboteur

首先我们将所有的点标记为0(即所有点放在一个集合里),然后每取出一个点标记为1(即将该点放在另一个集合里),直接暴力深搜,如果取出这个点,我们就遍历原来的集合,更新sum的数据,如果在同一个集合减去他们两个之间的权值,对于不在一个集合里的点,我们加上他们之间的权值。最后的结果为最大值。



C - Network Saboteur
Time Limit:2000MS     Memory Limit:65536KB     64bit IO Format:%I64d & %I64u

Description

A university network is composed of N computers. System administrators gathered information on the traffic between nodes, and carefully divided the network into two subnetworks in order to minimize traffic between parts.  
A disgruntled computer science student Vasya, after being expelled from the university, decided to have his revenge. He hacked into the university network and decided to reassign computers to maximize the traffic between two subnetworks.  
Unfortunately, he found that calculating such worst subdivision is one of those problems he, being a student, failed to solve. So he asks you, a more successful CS student, to help him.  
The traffic data are given in the form of matrix C, where Cij is the amount of data sent between ith and jth nodes (Cij = Cji, Cii = 0). The goal is to divide the network nodes into the two disjointed subsets A and B so as to maximize the sum ∑Cij (i∈A,j∈B).

Input

The first line of input contains a number of nodes N (2 <= N <= 20). The following N lines, containing N space-separated integers each, represent the traffic matrix C (0 <= Cij <= 10000).  
Output file must contain a single integer -- the maximum traffic between the subnetworks.  

Output

Output must contain a single integer -- the maximum traffic between the subnetworks.

Sample Input

3
0 50 30
50 0 40
30 40 0

Sample Output

90

#include <stdio.h>
#include <string.h>
#include <iostream>
#include <stack>
#include <queue>
#include <vector>
#include <cmath>
#include <algorithm>
#define mem(a,b) memset(a,b,sizeof(a))
using namespace std;
int a[50][50];
int v[40],n,t;
void dfs(int sum,int k)
{
	if(k==n)
	{
		return;
	}
	dfs(sum,k+1);
	v[k]=1;
	for(int i=0;i<n;i++)
	{
		if(v[i]==0)
		{
			sum+=a[k][i];
		}
		else{
			sum-=a[k][i];
		}
	}
	t=max(t,sum);
    dfs(sum,k+1);
    v[k]=0;
	
}
int main()
{
   while(cin>>n)
   {
   	 mem(v,0);
   	 t=0;
   	 for(int i=0;i<n;i++)
	   {
	   	for(int j=0;j<n;j++)
	   	{
	   		cin>>a[i][j];
		}
	   }
	   dfs(0,0);
	   cout<<t<<endl;
   }
}



猜你喜欢

转载自blog.csdn.net/qq_38570571/article/details/81032895