poj-3253(优先队列)

Description

Farmer John wants to repair a small length of the fence around the pasture. He measures the fence and finds that he needsN (1 ≤ N ≤ 20,000) planks of wood, each having some integer lengthLi (1 ≤ Li ≤ 50,000) units. He then purchases a single long board just long enough to saw into theN planks (i.e., whose length is the sum of the lengths Li). FJ is ignoring the "kerf", the extra length lost to sawdust when a sawcut is made; you should ignore it, too.

FJ sadly realizes that he doesn't own a saw with which to cut the wood, so he mosies over to Farmer Don's Farm with this long board and politely asks if he may borrow a saw.

Farmer Don, a closet capitalist, doesn't lend FJ a saw but instead offers to charge Farmer John for each of theN-1 cuts in the plank. The charge to cut a piece of wood is exactly equal to its length. Cutting a plank of length 21 costs 21 cents.

Farmer Don then lets Farmer John decide the order and locations to cut the plank. Help Farmer John determine the minimum amount of money he can spend to create theN planks. FJ knows that he can cut the board in various different orders which will result in different charges since the resulting intermediate planks are of different lengths.

Input

Line 1: One integer N, the number of planks

Lines 2..N+1: Each line contains a single integer describing the length of a needed plank

Output

Line 1: One integer: the minimum amount of money he must spend to makeN-1 cuts

Sample Input

3

8

5

8

Sample Output

34

Hint

He wants to cut a board of length 21 into pieces of lengths 8, 5, and 8.

The original board measures 8+5+8=21. The first cut will cost 21, and should be used to cut the board into pieces measuring 13 and 8. The second cut will cost 13, and should be used to cut the 13 into 8 and 5. This would cost 21+13=34. If the 21 was cut into 16 and 5 instead, the second cut would cost 16 for a total of 37 (which is more than 34).

题意:输入n个数代表要修的n个栅栏的长度,现在给你一个最够长的木板,你要用这个木板锯成n个这样的木条,(给定的木板长为这n个木板长度之和,最划算),现在规定每锯一块长为多少的木块就花费多少,(比如你要把长为x的木块锯成x1和x2,那么花费x,即被分割的木块多长就花费多少),问你最少花费多少可以得到这n块木块。

  我们采用逆向思维,将分割转化为拼接!!首先,含有n个木块得木块堆中找到最小的两个木块,让其拼接得到一块较大的木块,(这里拼接两块所需花费为这两个木块得长度和),将这块拼接好得木块加入到这些木块,从大到小排好序,然后取最小的两个木块,拼接。。。。重复上述步骤,直到所有的木块都拼接成一块为止。

实际上可以使用二叉堆,但是推荐优先队列

#include <iostream>
#include <stdio.h>
#include <queue>
#include <map>
 
using namespace std;
 
priority_queue<int, vector<int>, greater<int> > pr;
 
int main()
{
    long long n, sum = 0;
    cin >> n;
    long long length, min1, min2;
    while(n--)
    {
        scanf("%lld", &length);
        pr.push(length);
 
    }
    while(pr.size() > 1)
    {
        min1 = pr.top();
        pr.pop();
        min2 = pr.top();
        pr.pop();
        sum += min1 + min2;
        pr.push(min1 + min2);
    }
    cout << sum << endl;
    return 0;
}

猜你喜欢

转载自blog.csdn.net/qq_24016309/article/details/88710549