Java | PTA:jmu-Java-m06 统计一篇英文文章中出现的不重复单词的个数

输入一篇英文文章,碰到"!!!!!"的时候停止,输出文章中出现的不重复单词的个数(注意:单词不区分大小写,如:The和the为一个单词)

输入格式:

一篇英文文章,以"!!!!!"结尾

输出格式:

不重复单词的个数

输入样例:

Unmanned aerial vehicles have been adopted in the inspection of violations Procurators will file public interest litigations against perpetrators who will need to replant trees take down illegal buildings control pollution and compensate environment-related losses  
The Yellow River is the second longest river in China It originates in the northwestern province of Qinghai and runs through nine provinces and autonomous regions in western central north and eastern China  
!!!!!

输出样例:

55

import java.util.HashSet;
import java.util.Scanner;
import java.util.Set;

public class Main{
    public static void main(String[] args){
    	Scanner in = new Scanner(System.in);
    	Set<String> set = new HashSet<String>();
    	while(true) {
    		String aString = in.next();
    		if(aString.equals("!!!!!")) {
    			break;
    		}
    		set.add(aString.toLowerCase());
    	}
    	System.out.println(set.size());
    }
}

猜你喜欢

转载自blog.csdn.net/weixin_48419914/article/details/121229045