PTA jmu-Java-06异常-04-自定义异常(综合)分数 10

定义IllegalScoreException异常类,代表分数相加后超出合理范围的异常。该异常是checked exception,即希望该异常一定要被捕获处理。

定义IllegalNameException异常类,代表名字设置不合理的异常。该异常是unchecked exception

定义Student类。

属性:

private String name;
private int score;

方法:

toString          //自动生成
setter/getter     //自动生成
改造setName       //如果姓名首字母为数字则抛出IllegalNameException
public int addScore(int score)  //如果加分后分数<0 或>100,则抛出IllegalScoreException,加分不成功。

main方法

  1. 输入new则新建学生对象。然后输入一行学生数据,格式为姓名 年龄,接着调用setName,addScore。否则跳出循环。

  1. setName不成功则抛出异常,并打印异常信息,然后继续下一行的处理。

  1. addScore不成功则抛出异常,并打印异常信息,然后继续下一行的处理。如果2、3都成功,则打印学生信息(toString)

  1. 如果在解析学生数据行的时候发生其他异常,则打印异常信息,然后继续下一行的处理。

  1. Scanner也是一种资源,希望程序中不管有没有抛出异常,都要关闭。关闭后,使用System.out.println("scanner closed")打印关闭信息

注意:使用System.out.println(e);打印异常信息,e为所产生的异常。

输入样例:

new
zhang 10
new
wang 101
new
wang30
new
3a 100
new
wang 50
other

输出样例:

Student [name=zhang, score=10]
IllegalScoreException: score out of range, score=101
java.util.NoSuchElementException
IllegalNameException: the first char of name must not be digit, name=3a
Student [name=wang, score=50]
scanner closed

代码长度限制16 KB

时间限制400 ms

内存限制64 MB

import java.util.Scanner;

public class Main {
    public static void main(String[] args) throws IllegalNameException, IllegalScoreException {
        Scanner sc = new Scanner(System.in);
        while (true) {
            String str = sc.next();
            int flag = 0;
            if (str.equals("new")) {
                String name = sc.next();
                int score = 0;
                try {
                    score = sc.nextInt();
                } catch (Exception e) {
                    System.out.println("java.util.NoSuchElementException");
                    continue;
                }
                Student student = new Student(name, score);
                flag += student.setName(name);
                flag += student.addScore(score);
                if(flag == 2) System.out.println(student.toString());
            } else {
                break;
            }
        }
        sc.close();
        System.out.println("scanner closed");
    }
}

class Student {

    private String name;

    private int score;

    public Student() {
    }

    public Student(String name, int score) {
        this.name = name;
        this.score = score;
    }

    public String getName() {
        return name;
    }

    public int setName(String name) throws IllegalNameException {
        this.name = name;
        if(name.charAt(0)>'0' && name.charAt(0) < '9'){
            System.out.println("IllegalNameException: the first char of name must not be digit, name=" + name);
            return 0;
        }
        return 1;
    }

    public int getScore() {
        return score;
    }

    public void setScore(int score) {
        this.score = score;
    }

    @Override
    public String toString() {
        return "Student [" +
                "name=" + name +
                ", score=" + score +
                ']';
    }


    public int addScore(int score) throws IllegalScoreException {
        if (score < 0 || score > 100 ) {
            System.out.println("IllegalScoreException: score out of range, score=" + score);
            return 0;
        }
        return 1;
    }
}

class IllegalScoreException extends Exception{
    public IllegalScoreException() {
    }

    public IllegalScoreException(String message) {
        super(message);
    }
}

class IllegalNameException extends Exception{
    public IllegalNameException() {
    }

    public IllegalNameException(String message) {
        super(message);
    }
}

猜你喜欢

转载自blog.csdn.net/weixin_70206677/article/details/129343837