jmu-Java&Python-统计一段文字中的单词个数并按单词的字母顺序排序后输出

版权声明:本文为博主原创文章,未经博主允许不得转载。 https://blog.csdn.net/qq_42623428/article/details/84372842

现需要统计若干段文字(英文)中的不同单词数量。
如果不同的单词数量不超过10个,则将所有单词输出(按字母顺序),否则输出前10个单词。

注1:单词之间以空格(1个或多个空格)为间隔。
注2:忽略空行或者空格行。
注3:单词大小写敏感,即'word'与'WORD'是两个不同的单词 。

输入说明

若干行英文,最后以!!!!!为结束。

输出说明

不同单词数量。 然后输出前10个单词(按字母顺序),如果所有单词不超过10个,则将所有的单词输出。

输入样例

Failure is probably the fortification in your pole
It is like a peek your wallet as the thief when you
are thinking how to spend several hard-won lepta
when you Are wondering whether new money it has laid
background Because of you, then at the heart of the
most lax alert and most low awareness and left it
godsend failed
!!!!!

输出样例

49
Are
Because
Failure
It
a
alert
and
are
as
at
import java.util.*;

public class Main{

	public static void main(String[] args) {
		Set<String> s=new TreeSet<String>();
		Scanner scan=new Scanner(System.in);
		String text = "",temp;
		while(true) {
			temp=scan.next();
			if(temp.equals("!!!!!"))break;
			s.add(temp);
		}
		
		System.out.println(s.size());
		Iterator<String> i=s.iterator();
		if(s.size()<10) {
			while(i.hasNext()) {
				System.out.println(i.next());
			}
		}
		else {
			for(int j=0;j<10;j++) {
				System.out.println(i.next());
			}
		}
		scan.close();
	}
}

猜你喜欢

转载自blog.csdn.net/qq_42623428/article/details/84372842