HDU - 1551 Cable master

问题描述:

Inhabitants of the Wonderland have decided to hold a regional programming contest. The Judging Committee has volunteered and has promised to organize the most honest contest ever. It was decided to connect computers for the contestants using a “star” topology - i.e. connect them all to a single central hub. To organize a truly honest contest, the Head of the Judging Committee has decreed to place all contestants evenly around the hub on an equal distance from it.

To buy network cables, the Judging Committee has contacted a local network solutions provider with a request to sell for them a specified number of cables with equal lengths. The Judging Committee wants the cables to be as long as possible to sit contestants as far from each other as possible.

The Cable Master of the company was assigned to the task. He knows the length of each cable in the stock up to a centimeter, and he can cut them with a centimeter precision being told the length of the pieces he must cut. However, this time, the length is not known and the Cable Master is completely puzzled.

You are to help the Cable Master, by writing a program that will determine the maximal possible length of a cable piece that can be cut from the cables in the stock, to get the specified number of pieces.

输入说明:

The input consists of several testcases. The first line of each testcase contains two integer numbers N and K, separated by a space. N (1 ≤ N ≤ 10000) is the number of cables in the stock, and K (1 ≤ K ≤ 10000) is the number of requested pieces. The first line is followed by N lines with one number per line, that specify the length of each cable in the stock in meters. All cables are at least 1 centimeter and at most 100 kilometers in length. All lengths in the input are written with a centimeter precision, with exactly two digits after a decimal point.

The input is ended by line containing two 0’s.

输出说明:

For each testcase write to the output the maximal length (in meters) of the pieces that Cable Master may cut from the cables in the stock to get the requested number of pieces. The number must be written with a centimeter precision, with exactly two digits after a decimal point.

If it is not possible to cut the requested number of pieces each one being at least one centimeter long, then the output must contain the single number “0.00” (without quotes).

SAMPLE INPUT:

4 11
8.02
7.43
4.57
5.39
0 0

SAMPLEOUTPUT:

2.00

思路:

题意就是要我们找切割电缆时候,电缆的最长长度,和前一道题目的思路差不多,先对输入从大到小排列,然后取最长的电缆作为终点,0作为起点开始二分,对二分中的每一个值,都要进行检验,判断能不能减出需要的电缆数量来。

扫描二维码关注公众号,回复: 12905977 查看本文章

AC代码:

#include <bits/stdc++.h>
using namespace std;
double a[100000];
int n,m,i;
int check(double x)
{
    
    
    int sum=0;
    for(int i=0;i<n;i++)
    {
    
    
        sum+=(int)(a[i]/x);
    }
    if(sum>=m)
        return 1;
    return 0;
}
bool com(int a,int b)
{
    
    
    return a>b;
}
int main()

{
    
    
    while(scanf("%d%d",&n,&m)&&n&&m)
    {
    
    
        for(i=0;i<n;i++)
        {
    
    
            cin>>a[i];
        }
        sort(a,a+n,com);
        double r=0.0,l=a[0]*1.0,middle;
        for(i=0;i<100;i++)
        {
    
    
            middle=(l+r)/2;
            if(check(middle))
            {
    
    
                r=middle;
            }
            else
            {
    
    
                l=middle;
            }
        }
        middle=(l+r)/2;
        int temp=middle*100;
        cout<<fixed<<setprecision(2)<<temp*0.01<<endl;
    }

}




猜你喜欢

转载自blog.csdn.net/m0_51727949/article/details/115179037
今日推荐