练习4.1 根据后序和中序遍历输出先序遍历 (25 分)

传送门
本题要求根据给定的一棵二叉树的后序遍历和中序遍历结果,输出该树的先序遍历结果。

输入格式:
第一行给出正整数N(≤30),是树中结点的个数。随后两行,每行给出N个整数,分别对应后序遍历和中序遍历结果,数字间以空格分隔。题目保证输入正确对应一棵二叉树。

输出格式:
在一行中输出Preorder: 以及该树的先序遍历结果。数字间有1个空格,行末不得有多余空格。

输入样例:

7
2 3 1 5 7 6 4
1 2 3 4 5 6 7

输出样例:

Preorder: 4 1 3 2 6 5 7
#include<iostream>
using namespace std;
int n,in[31],post[31];
void preorder(int root,int start,int end)
{
    
    
	if(start>end)return ;
	int i=end;
	while(i>start&&in[i]!=post[root])i--;
	printf(" %d",post[root]);
	preorder(root-1-(end-i),start,i-1);
	preorder(root-1,i+1,end);
}
int main()
{
    
    
	cin>>n;
	for(int i=0;i<n;i++)
		cin>>post[i];
	for(int i=0;i<n;i++)
		cin>>in[i];
	printf("Preorder:");
	preorder(n-1,0,n-1);
}

猜你喜欢

转载自blog.csdn.net/weixin_49640089/article/details/114109690