7-5 还原二叉树 (25 分)(二叉树,根据 中序遍历 和 先序遍历)

7-5 还原二叉树 (25 分)

给定一棵二叉树的先序遍历序列和中序遍历序列,要求计算该二叉树的高度。

输入格式:

输入首先给出正整数N(≤50),为树中结点总数。下面两行先后给出先序和中序遍历序列,均是长度为N的不包含重复英文字母(区别大小写)的字符串。

输出格式:

输出为一个整数,即该二叉树的高度。

输入样例:

9
ABDFGHIEC
FDHGIBEAC

输出样例:

5

#include<iostream>
#include<vector>
#include<cstdio>
#include<set>
#include<map>
#include<string>
#include<string.h>
#include<algorithm>
#include<cmath>
#include<stdlib.h>
#include<ctype.h>
#include<stack>
#include<queue>
#include<list>
using namespace std;

typedef struct node{
    struct node* left;
    struct node* right;
    char data;
}node;
node* BitryTree(char a[],char b[],int n){
    node *T;
    int i;
    if(!n)
        return NULL;
    else{
        T = (node *)malloc(sizeof(struct node));
        T->data = a[0];
        for(i=0;i<n;i++){
            if(a[0]==b[i])
                break;
        }
        T->left = BitryTree(a+1,b,i);
        T->right = BitryTree(a+1+i,b+i+1,n-i-1);
    }
    return T;
};
int getHight(node* T){
    int hl,hr,hight;
    if(!T)
        return 0;
    else{
        hl=getHight(T->left);
        hr=getHight(T->right);
        hight=hl>hr?hl:hr;
        hight++;
    }
    return hight;
}
int main(){
    int n;
    char a[55];
    char b[55];
    scanf("%d",&n);
    scanf("%s",a);
    scanf("%s",b);
    node *tree = BitryTree(a,b,n);
    int hight = getHight(tree);
    cout<<hight<<endl;
    return  0;
}

猜你喜欢

转载自blog.csdn.net/qq_40099908/article/details/82851572