抓牛

Farmer John has been informed of the location of a fugitive cow and wants to catch her immediately. He starts at a point N (0 ≤ N ≤ 100,000) on a number line and the cow is at a point K (0 ≤ K ≤ 100,000) on the same number line. Farmer John has two modes of transportation: walking and teleporting.

  • Walking: FJ can move from any point X to the points X - 1 or X + 1 in a single minute
  • Teleporting: FJ can move from any point X to the point 2 × X in a single minute.

If the cow, unaware of its pursuit, does not move at all, how long does it take for Farmer John to retrieve it?

Input
Line 1: Two space-separated integers: N and K
Output
Line 1: The least amount of time, in minutes, it takes for Farmer John to catch the fugitive cow.
Sample Input
5 17
Sample Output
4
Hint
The fastest way for Farmer John to reach the fugitive cow is to move along the following path: 5-10-9-18-17, which takes 4 minutes.
注意://注意了!两个相关判断,vis数组范围注意。先判断em.n<110000才能看vis,否则越界
bfs模板,不是数学问题的,与每次多跳一格有这个技巧不同

#include<iostream>
#include<stdio.h>
#include<queue>
using namespace std;
int k;
struct node{
    
    
	int n,t;
}s,em;
int vis[110005]={
    
    0};//0未1有 
int bfs(void){
    
    
	queue<node>q;
	s.t=0;
	vis[s.n]=1; 
	q.push(s);
	while(!q.empty()){
    
    
		s=q.front();
		q.pop();
		if(s.n==k)return s.t;
		em.t=s.t+1;//下一个 
		//x-1
		em.n=s.n-1;
		if(vis[em.n]==0&&em.n>=0){
    
    
			vis[em.n]=1;
			q.push(em);
		}
		if(s.n<k)
		{
    
    
			//x+1
			em.n=s.n+1;
			if(em.n<110000&&vis[em.n]==0){
    
    //注意了!两个相关判断,vis数组范围注意。先判断em.n<110000才能看vis,否则越界 
				vis[em.n]=1;
				q.push(em);
			}
			//2x
			em.n=2*s.n;
			if(em.n<110000&&vis[em.n]==0){
    
    
				vis[em.n]=1;
				q.push(em);
			}
		}
	}
}
int main()
{
    
    
	scanf("%d%d",&s.n,&k);
	printf("%d",bfs());
	return 0;
}

猜你喜欢

转载自blog.csdn.net/qq_51945248/article/details/113772247