【Trie】hdu 1247 Hat’s Words

Hat’s Words

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 22924    Accepted Submission(s): 8049


 

Problem Description
A hat’s word is a word in the dictionary that is the concatenation of exactly two other words in the dictionary.
You are to find all the hat’s words in a dictionary.
 
Input
Standard input consists of a number of lowercase words, one per line, in alphabetical order. There will be no more than 50,000 words.
Only one case.
 
Output
Your output should contain all the hat’s words, one per line, in alphabetical order.
 
Sample Input
 
a ahat hat hatword hziee word
 
Sample Output
 
ahat hatword
 
 
建了Trie树之后,直接枚举查找即可
 
 
代码
#include<bits/stdc++.h>
using namespace std;
char c[50005][30];
int ch[50005][30],k,tot,cnt[50005];
void insert(char *s)
{
	int now=0,len=strlen(s);
	for(int i=0;i<len;i++)
	{
		int dig=s[i]-'a';
		if(!ch[now][dig]) ch[now][dig]=++tot;
		now=ch[now][dig];
	}
	cnt[now]=1;
}
int check(int k,int pos)
{
	int now=0,len=strlen(c[k]);
	for(int i=pos;i<len;i++)
	{
		int dig=c[k][i]-'a';
		if(!ch[now][dig]) return 0;
		now=ch[now][dig]; 
	}
	if(cnt[now]>0) return 1;
	else return 0;
}
int find(int k)
{
	int now=0,len=strlen(c[k]);
	for(int i=0;i<len;i++)
	{
		int dig=c[k][i]-'a';
		if(cnt[now]>0 && check(k,i)) return 1;
		now=ch[now][dig]; 
	}
	return 0;
}
int main()
{
	freopen("a.in","r",stdin);
	freopen("a.out","w",stdout);
	while(scanf("%s",c[++k])!=EOF)
	{
		insert(c[k]);
	}
	for(int i=1;i<=k;i++)
		if(find(i))
		{
			for(int j=0;j<strlen(c[i]);j++)
				printf("%c",c[i][j]);
			printf("\n");
		}
	return 0;
}

猜你喜欢

转载自blog.csdn.net/andyc_03/article/details/110074848
今日推荐