【HDU 1247】Hat’s Words(字典树)

Hat’s Words

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)

Problem Description

A hat’s word is a word in the dictionary that is the concatenation of exactly two other words in the dictionary.
You are to find all the hat’s words in a dictionary.

Input

Standard input consists of a number of lowercase words, one per line, in alphabetical order. There will be no more than 50,000 words.
Only one case.

Output

Your output should contain all the hat’s words, one per line, in alphabetical order.

Sample Input

a
ahat
hat
hatword
hziee
word

Sample Output

ahat
hatword

题目大意:在你输入的这些单词中,找到那些由已有单词拼接出来的单词。比如有a和hat你就要输出ahat。由于测试样例都是按照字典序我们就降低复杂度不用排序了。

字典树入门:
http://blog.csdn.net/hguisu/article/details/8131559 http://blog.csdn.net/thesprit/article/details/52065241

我们创建字典树。将所有输入的单词都放进去。然后再开始这样做:找到一个完整的单词,找到以这个单词为前缀的单词return true否则都返回false。

为了方便对子串的操作,建议使用string以及它的函数substr()。

#include "iostream"
#include "cstdio"
#include "cstring"
#include "algorithm"
#include "malloc.h"

using namespace std;

const int maxn = 1e5+5;
const int MAX = 26;

string s[maxn];

struct Trie{
    int v;
    bool exit;
    Trie *next[MAX];
    Trie(){
        v=0;
        exit = false;
        memset(next,0,sizeof(next));
    }
};

Trie *root = new Trie();

void CreateTrie( string str ){
    Trie *p = root;
    for( int i=0 ; i<str.size() ; i++ ){
        int num = str[i]-'a';
        if( p->next[num] == NULL ) p->next[num] = new Trie();
        p = p->next[num];
    }
    p->exit = true;
}

bool FindTrie( string str ){
    Trie *p = root;
    for( int i=0 ; i<str.size() ; i++ ){
        int num = str[i]-'a';
        if(p->next[num] == NULL) return false;
        p = p->next[num];
    }
    return p->exit;
}

bool FindCombination( string str ){
    Trie *p = root;
    for( int i=0 ; i<str.size() ; i++ ){
        int num = str[i]-'a';
        if(p->next[num] == NULL) return false;
        p = p->next[num];
        if(p->exit && FindTrie(str.substr(i+1))) return true;
    }
    return false;
}

int main(){
    string str;
    int k=0;
    while(cin>>str){
        s[k++] = str;
        CreateTrie(str);
    }
    for( int i=0 ; i<k ; i++ ){
        if(FindCombination(s[i])) cout<<s[i]<<endl;
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/thesprit/article/details/52083889