HDU - 1200 To and Fro

Mo and Larry have devised a way of encrypting messages. They first decide secretly on the number of columns and write the message (letters only) down the columns, padding with extra random letters so as to make a rectangular array of letters. For example, if the message is “There’s no place like home on a snowy night” and there are five columns, Mo would write down

t o i o y
h p k n n
e l e a i
r a h s g
e c o n h
s e m o t
n l e w x

Note that Mo includes only letters and writes them all in lower case. In this example, Mo used the character ‘x’ to pad the message out to make a rectangle, although he could have used any letter.

Mo then sends the message to Larry by writing the letters in each row, alternating left-to-right and right-to-left. So, the above would be encrypted as

toioynnkpheleaigshareconhtomesnlewx

Your job is to recover for Larry the original message (along with any extra padding letters) from the encrypted one.
Input
There will be multiple input sets. Input for each set will consist of two lines. The first line will contain an integer in the range 2. . . 20 indicating the number of columns used. The next line is a string of up to 200 lower case letters. The last input set is followed by a line containing a single 0, indicating end of input.
Output
Each input set should generate one line of output, giving the original plaintext message, with no spaces.
Sample Input
5
toioynnkpheleaigshareconhtomesnlewx
3
ttyohhieneesiaabss
0
Sample Output
theresnoplacelikehomeonasnowynightx
thisistheeasyoneab
题意描述:

解题思路:
就是把加密过的字符串,按照原来加密规则逆向加密
具体操作看下面的样例分析

toioynnkpheleaigshareconhtomesnlewx

将字符串化成n列矩阵 
toioy
nnkph
eleai
gshar
econh
tomes
nlewx

偶数行逆序 
toioy
hpknn //逆序 
eleai
rahsg //逆序
econh
semot //逆序
nlewx

按列遍历矩阵 
theresnoplacelikehomeonasnowynightx

AC代码

#include <stdio.h>
#include <string.h>

char a[500];
char b[100][100];
int main()
{
    
    
    int n;
    while(scanf("%d",&n))
    {
    
    
        if(!n)
            break;
        getchar();
        gets(a);
        int len,i,j,k=0;
        
        len=strlen(a);
        len=len/n;
        for(i=0;i<len;i++)//将字符串化成n列矩阵 
            for(j=0;j<n;j++)
                b[i][j]=a[k++];
        for(i=0;i<len;i++)
        	 if(i%2==0)//偶数行逆序 
				for(j=0;j<n/2;j++)//二分法 
		        {
    
    
		            int t=b[i][j];
		            b[i][j]=b[i][n-j-1];
		            b[i][n-j-1]=t;
		        }
        for(j=0;j<n;j++)//按列遍历矩阵 
            for(i=0;i<len;i++)
            {
    
    
                    printf("%c",b[i][n-j-1]);
            }
        printf("\n");
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/weixin_46703995/article/details/112995417
今日推荐