To and Fro

Mo and Larry have devised a way of encrypting messages. They first decide secretly on the number of columns and write the message (letters only) down the columns, padding with extra random letters so as to make a rectangular array of letters. For example, if the message is “There’s no place like home on a snowy night” and there are five columns, Mo would write down

t o i o y
h p k n n
e l e a i
r a h s g
e c o n h
s e m o t
n l e w x

Note that Mo includes only letters and writes them all in lower case. In this example, Mo used the character ‘x’ to pad the message out to make a rectangle, although he could have used any letter.

Mo then sends the message to Larry by writing the letters in each row, alternating left-to-right and right-to-left. So, the above would be encrypted as

toioynnkpheleaigshareconhtomesnlewx

Your job is to recover for Larry the original message (along with any extra padding letters) from the encrypted one.
Input
There will be multiple input sets. Input for each set will consist of two lines. The first line will contain an integer in the range 2. . . 20 indicating the number of columns used. The next line is a string of up to 200 lower case letters. The last input set is followed by a line containing a single 0, indicating end of input.
Output
Each input set should generate one line of output, giving the original plaintext message, with no spaces.
Sample Input
5
toioynnkpheleaigshareconhtomesnlewx
3
ttyohhieneesiaabss
0
Sample Output
theresnoplacelikehomeonasnowynightx
thisistheeasyoneab

题意分析:给出一行字符串和一个数字,把字符串按s型排列,一行n个字符,然后再一列一列输出字符

#include<stdio.h>
#include<string.h>
int main()
{
    
    
    char s[200][200],a[201];
    int l,i,j,k,t,n;
    while(scanf("%d",&n)&&n)
   
    	memset(s,'\0',sizeof(s));//初始化二维字符串
    	scanf("%s",a);
    	l=strlen(a);
    	k=l/n;//行数
    	t=0;//输入字符串的下标
    	for(i=0;i<k;i++)
    	for(j=0;j<n;j++)
    	{
    
    
    		if(i%2==1)//奇数行逆序存
    		s[i][n-j-1]=a[t++];
    		else//偶数行正序存
    		s[i][j]=a[t++];
		}
		//输出注意列在前,行在后,要输出每一列的每一行。
		for(i=0;i<n;i++)
    	for(j=0;j<k;j++)
    	printf("%c",s[j][i]);
		printf("\n");
	}
} 

猜你喜欢

转载自blog.csdn.net/m0_46381590/article/details/113034685