Eeny Meeny Moo POJ - 2244(约瑟夫环递推)

Surely you have made the experience that when too many people use the Internet simultaneously, the net becomes very, very slow.
To put an end to this problem, the University of Ulm has developed a contingency scheme for times of peak load to cut off net access for some cities of the country in a systematic, totally fair manner. Germany’s cities were enumerated randomly from 1 to n. Freiburg was number 1, Ulm was number 2, Karlsruhe was number 3, and so on in a purely random order.
Then a number m would be picked at random, and Internet access would first be cut off in city 1 (clearly the fairest starting point) and then in every mth city after that, wrapping around to 1 after n, and ignoring cities already cut off. For example, if n=17 and m=5, net access would be cut off to the cities in the order [1,6,11,16,5,12,2,9,17,10,4,15,14,3,8,13,7]. The problem is that it is clearly fairest to cut off Ulm last (after all, this is where the best programmers come from), so for a given n, the random number m needs to be carefully chosen so that city 2 is the last city selected.

Your job is to write a program that will read in a number of cities n and then determine the smallest integer m that will ensure that Ulm can surf the net while the rest of the country is cut off.
Input
The input will contain one or more lines, each line containing one integer n with 3 <= n < 150, representing the number of cities in the country.
Input is terminated by a value of zero (0) for n.
Output
For each line of the input, print one line containing the integer m fulfilling the requirement specified above.
Sample Input
3
4
5
6
7
8
9
10
11
12
0
Sample Output
2
5
2
4
3
11
2
3
8
16

题意:
从第一个数开始,第一个数首先删除,之后每次删除当前第m个数(循环数组)。
求一个m使得最后剩下的是第二个数。

思路:
就是约瑟夫环求幸存者,枚举m然后线性递推。

递推公式 f [ n ] = ( f [ n 1 ] + m ) m o d    n f[n]=(f[n−1]+m) \mod n

证明:
ACWING82. 圆圈中最后剩下的数字(剑指offer,约瑟夫问题)

#include <cstdio>
#include <cstring>
#include <cmath>
#include <cstdlib>
#include <vector>
#include <map>
#include <iostream>
#include <algorithm>
using namespace std;

int f[155];

int F(int n,int m) {
    memset(f,0,sizeof(f));
    f[0] = 0;
    for(int i = 1;i < n;i++) {
        f[i] = (f[i - 1] + m) % (i + 1);
    }
    return f[n - 1];
}

int main() {
    int n;
    while(~scanf("%d",&n) && n) {
        for(int m = 1;m <= 1000;m++) {
            int x = F(n - 1,m);
            if(x == 0) {
                printf("%d\n",m);
                break;
            }
        }
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/tomjobs/article/details/108342321