POJ2010 Moo University - Financial Aid【中位数+优先队列】

Time Limit: 1000MS   Memory Limit: 30000K
Total Submissions: 11088   Accepted: 3261

Description

Bessie noted that although humans have many universities they can attend, cows have none. To remedy this problem, she and her fellow cows formed a new university called The University of Wisconsin-Farmside,"Moo U" for short.  

Not wishing to admit dumber-than-average cows, the founders created an incredibly precise admission exam called the Cow Scholastic Aptitude Test (CSAT) that yields scores in the range 1..2,000,000,000.  

Moo U is very expensive to attend; not all calves can afford it.In fact, most calves need some sort of financial aid (0 <= aid <=100,000). The government does not provide scholarships to calves,so all the money must come from the university's limited fund (whose total money is F, 0 <= F <= 2,000,000,000).  

Worse still, Moo U only has classrooms for an odd number N (1 <= N <= 19,999) of the C (N <= C <= 100,000) calves who have applied.Bessie wants to admit exactly N calves in order to maximize educational opportunity. She still wants the median CSAT score of the admitted calves to be as high as possible.  

Recall that the median of a set of integers whose size is odd is the middle value when they are sorted. For example, the median of the set {3, 8, 9, 7, 5} is 7, as there are exactly two values above 7 and exactly two values below it.  

Given the score and required financial aid for each calf that applies, the total number of calves to accept, and the total amount of money Bessie has for financial aid, determine the maximum median score Bessie can obtain by carefully admitting an optimal set of calves.  

Input

* Line 1: Three space-separated integers N, C, and F  

* Lines 2..C+1: Two space-separated integers per line. The first is the calf's CSAT score; the second integer is the required amount of financial aid the calf needs  

Output

* Line 1: A single integer, the maximum median score that Bessie can achieve. If there is insufficient money to admit N calves,output -1.  

Sample Input

3 5 70
30 25
50 21
20 20
5 18
35 30

Sample Output

35

Hint

Sample output:If Bessie accepts the calves with CSAT scores of 5, 35, and 50, the median is 35. The total financial aid required is 18 + 30 + 21 = 69 <= 70.  

Source


问题链接POJ2010 Moo University - Financial Aid

问题简述

扫描二维码关注公众号,回复: 510146 查看本文章

  新建一个大学,给N(奇数)个学生提供助学金,该学校最多能提供助学金数额为F。总共有C个学生,同时给出学生成绩与助学金,学校希望这个N个学生的成绩的中位数尽可能地大,求这个中位数的最大值。

问题分析:(略)

程序说明:(略)

题记:(略)

参考链接:(略)


AC的C++语言程序如下:

/* POJ2010 Moo University - Financial Aid */

#include <iostream>
#include <algorithm>
#include <queue>

using namespace std;

const int N = 1e5;
pair<int, int> cow[N + 1];
int lower[N + 1], upper[N + 1];

int main()
{
    std::ios::sync_with_stdio(false);

    int n, c, f;

    cin >> n >> c >> f;
    for(int i=1; i<=c; i++)
        cin >> cow[i].first >> cow[i].second;

    sort(cow+1,cow+1+c);

    int half = n / 2;
    if( n > 1) {
        priority_queue<int>q;
        int sum = 0;
        for(int i = 1; i <= half; i++) {
            q.push(cow[i].second);
            sum += cow[i].second;
        }
        for(int i = half + 1; i <= c - half; i++) {
            lower[i] = sum;
            int p = q.top();
            if(cow[i].second < p){
                q.pop();
                q.push(cow[i].second);
                sum += cow[i].second - p;
            }
        }
        while(q.size()) q.pop();
        sum=0;
        for(int i = c; i >= c - half + 1; i--) {
            q.push(cow[i].second);
            sum += cow[i].second;
        }
        for(int i = c - half; i >= half + 1; i--) {
            upper[i] = sum;
            int p = q.top();
            if(cow[i].second < p) {
                q.pop();
                q.push(cow[i].second);
                sum += cow[i].second - p;
            }
        }
    }

    int ans = -1;
    for(int i = c - half; i >= half + 1; i--)
        if(lower[i] + upper[i] + cow[i].second <= f) {
            ans = cow[i].first;
            break;
        }

    cout << ans << endl;

    return 0;
}






猜你喜欢

转载自blog.csdn.net/tigerisland45/article/details/80174095
今日推荐