PTA甲级 1101 Quick Sort (25分)


首先,先贴柳神的博客

https://www.liuchuo.net/ 这是地址

想要刷好PTA,强烈推荐柳神的博客,和算法笔记

题目原文

There is a classical process named partition in the famous quick sort algorithm. In this process we typically choose one element as the pivot. Then the elements less than the pivot are moved to its left and those larger than the pivot to its right. Given N distinct positive integers after a run of partition, could you tell how many elements could be the selected pivot for this partition?

For example, given N=5 and the numbers 1, 3, 2, 4, and 5. We have:

  • 1 could be the pivot since there is no element to its left and all the elements to its right are larger than it;
  • 3 must not be the pivot since although all the elements to its left are smaller, the number 2 to its right is less than it as well;
  • 2 must not be the pivot since although all the elements to its right are larger, the number 3 to its left is larger than it as well;
  • and for the similar reason, 4 and 5 could also be the pivot.

Hence in total there are 3 pivot candidates.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (≤105). Then the next line contains N distinct positive integers no larger than 109. The numbers in a line are separated by spaces.

Output Specification:

For each test case, output in the first line the number of pivot candidates. Then in the next line print these candidates in increasing order. There must be exactly 1 space between two adjacent numbers, and no extra space at the end of each line.

Sample Input:

5
1 3 2 4 5

Sample Output:

3
1 4 5

题目大意:

一个数组,要你求出,这个数组里那些数可以用来当做主元.

主元的定义:

主元左边的数,都要比主元小,主元右边的数都要比主元大.

最左的数,就不用考虑左边,同理最右.

思路如下:

① 判断一个数,是不是主元,我们只要知道,这个数,左边最大的数是不是小于这个数,右边最小的数,是不是大于这个数.

② 我们用两个数组,一个是leftMax,一个是rightMin,用来记录,每个数,左边最大和右边最小–都不包括自己.

代码如下

#include<iostream>
#include<vector>
#include<string>
#include<inttypes.h>
using namespace std;


int main(void){
	unsigned int N;
	scanf("%d",&N);
	vector<long long> data(N);
	vector<long long> leftMax(N);
	leftMax.push_back(-1);
	scanf("%I64d",&data[0]);
	for(unsigned int i=1;i<N;++i){
		scanf("%I64d",&data[i]);
		leftMax[i] = max(leftMax[i-1],data[i-1]);	
	}
	vector<long long> rightMin(N);
	rightMin[N-1] = 999999999;
	for(int i=N-2;i>=0;--i){
		rightMin[i] = min(rightMin[i+1],data[i+1]);
	}
	vector<long long> ans;
	for(unsigned int i=0;i<N;i++){
		if(leftMax[i]<data[i]&&rightMin[i]>data[i])
			ans.push_back(data[i]);
	}
	printf("%d\n",ans.size());

	for(unsigned  int i=0;i<ans.size();i++){
		cout<<ans[i];
		if(i<ans.size()-1)
			cout<<" ";
	}

	cout<<"\n";
	return 0;
}

下面是分享的柳神的代码

地址

#include <iostream>
#include <algorithm>
#include <vector>
int v[100000];
using namespace std;
int main() {
    int n, max = 0, cnt = 0;
    scanf("%d", &n);
    vector<int> a(n), b(n);
    for (int i = 0; i < n; i++) {
        scanf("%d", &a[i]);
        b[i] = a[i];
    }
    sort(a.begin(), a.end());
    for (int i = 0; i < n; i++) {
        if(a[i] == b[i] && b[i] > max)
            v[cnt++] = b[i];
        if (b[i] > max)
            max = b[i];
    }
    printf("%d\n", cnt);
    for(int i = 0; i < cnt; i++) {
        if (i != 0) printf(" ");
        printf("%d", v[i]);
    }
    printf("\n");
    return 0;
}

猜你喜欢

转载自blog.csdn.net/Huangpengyu123/article/details/106978089
今日推荐