1101 Quick Sort (25分)

There is a classical process named partition in the famous quick sort algorithm. In this process we typically choose one element as the pivot. Then the elements less than the pivot are moved to its left and those larger than the pivot to its right. Given N distinct positive integers after a run of partition, could you tell how many elements could be the selected pivot for this partition?

For example, given N=5 and the numbers 1, 3, 2, 4, and 5. We have:

  • 1 could be the pivot since there is no element to its left and all the elements to its right are larger than it;
  • 3 must not be the pivot since although all the elements to its left are smaller, the number 2 to its right is less than it as well;
  • 2 must not be the pivot since although all the elements to its right are larger, the number 3 to its left is larger than it as well;
  • and for the similar reason, 4 and 5 could also be the pivot.

Hence in total there are 3 pivot candidates.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (≤10​5​​). Then the next line contains N distinct positive integers no larger than 10​9​​. The numbers in a line are separated by spaces.

Output Specification:

For each test case, output in the first line the number of pivot candidates. Then in the next line print these candidates in increasing order. There must be exactly 1 space between two adjacent numbers, and no extra space at the end of each line.

Sample Input:

5
1 3 2 4 5

Sample Output:

3
1 4 5

题意:数处枢纽元素的个数,并按从小到大输出。

思路:设置三个数组,a,b,max,其中a内放输入的元素,b内放排序后的元素,max[i]内保存下标i之前最大的元素(不含下标为i的元素),若满足以下条件,及为中枢元素:

1.a[i] = b[i];

2.max[i] < a[i];

#include<vector>
#include<algorithm>
#include<iostream>
using namespace std;

int main(){

    int n;
    cin >> n;
    vector<int> vec_a(n);
    vector<int> vec_b(n);
    vector<int> vec_max(n);

    vector<int> vec_c;
    scanf("%d", &vec_a[0]);
    vec_b[0] = vec_a[0];
    vec_max[0] = -1;
    for(int i = 1; i < n; i++){
        scanf("%d", &vec_a[i]);
        vec_b[i] = vec_a[i];
        vec_max[i] = max(vec_max[i - 1], vec_a[i - 1]);
    } 
    sort(vec_b.begin(), vec_b.end());

    for(int i = 0; i < n; i++){
        if(vec_a[i] == vec_b[i] && vec_max[i] < vec_a[i]){
            
           
            vec_c.push_back(vec_a[i]);
            
        }

    }
    sort(vec_c.begin(), vec_c.end());
    printf("%d\n", int(vec_c.size()));
    for(int i = 0; i < int(vec_c.size()); i++){

        printf("%s%d", i != 0 ? " " : "", vec_c[i]);

    }
    printf("\n");
    return 0;
}
发布了86 篇原创文章 · 获赞 15 · 访问量 1112

猜你喜欢

转载自blog.csdn.net/zbchenchanghao/article/details/104174500