HDU - 3792- Twin Prime Conjecture【 数论 】 题解

1.题目

If we define dn as: dn = pn+1-pn, where pi is the i-th prime. It is easy to see that d1 = 1 and dn=even for n>1. Twin Prime Conjecture states that “There are infinite consecutive primes differing by 2”.
Now given any positive integer N (< 10^5), you are supposed to count the number of twin primes which are no greater than N.
Input
Your program must read test cases from standard input.
The input file consists of several test cases. Each case occupies a line which contains one integer N. The input is finished by a negative N.
Output
For each test case, your program must output to standard output. Print in one line the number of twin primes which are no greater than N.
Sample Input
1
5
20
-2
Sample Output
0
1
4

2.代码

#include<iostream>
#include<cstdio>
using namespace std;
const int maxn=1e6+10;
int a[maxn],prime[maxn];
void isPrime()
{
  prime[1]=1;
  prime[0]=1;
  for(int i=2;i<maxn;i++)
  {
     if(prime[i]==0)
	 {
	 	 for(int j=i+i;j<maxn;j+=i)
	 	  prime[j]=1;
	 }	
  }	
} 
int main()
{   
    isPrime();
    a[5]=1;///初值 
    for(int i=1;i<maxn;i++)
    {
    	a[i+2]=a[i+1];  ///递推式 
    	if(prime[i]==0&&prime[i+2]==0)
    	  a[i+2]=a[i+1]+1;
	}
	int n;
	while(cin>>n)
	{
		if(n<0)  break;
		cout<<a[n]<<endl;
	}
	return 0;
}

猜你喜欢

转载自blog.csdn.net/weixin_45629285/article/details/106795052
今日推荐