AtCoder Context 141D-Powerful Discount Tickets【优先队列】 难度:**

题意:

Takahashi is going to buy N items one by one.

The price of the i-th item he buys is Ai yen (the currency of Japan).

He has M discount tickets, and he can use any number of them when buying an item.

If Y tickets are used when buying an item priced X yen, he can get the item for X 2Y (rounded down to the nearest integer) yen.

What is the minimum amount of money required to buy all the items?

Constraints
All values in input are integers.
1≤N,M≤105
1≤Ai≤109
Input
Input is given from Standard Input in the following format:

N M
A1 A2 … AN
Output
Print the minimum amount of money required to buy all the items.

Sample Input 1
Copy
3 3
2 13 8
Sample Output 1
Copy
9
We can buy all the items for 9 yen, as follows:

Buy the 1-st item for 2 yen without tickets.
Buy the 2-nd item for 3 yen with 2 tickets.
Buy the 3-rd item for 4 yen with 1 ticket.
Sample Input 2
Copy
4 4
1 9 3 5
Sample Output 2
Copy
6
Sample Input 3
Copy
1 100000
1000000000
Sample Output 3
Copy
0
We can buy the item priced 1000000000 yen for 0 yen with 100000 tickets.

Sample Input 4
Copy
10 1
1000000000 1000000000 1000000000 1000000000 1000000000 1000000000 1000000000 1000000000 1000000000 1000000000
Sample Output 4
Copy
9500000000

题解:

贪心即可,每次都对价格最高的票使用一次优惠券,因此可以把价格放入优先队列,每次取队首进行处理,直到优惠券全部用完为止。

代码:

#include<iostream>
#include<queue>
using namespace std;
long long a[100005];
int main()
{
	long long n,m,k,price,sum=0;
	priority_queue<long long>que;
	scanf("%lld%lld",&n,&m);
	for(int i=0;i<n;i++)scanf("%lld",&a[i]);
	for(int i=0;i<n;i++)que.push(a[i]);
	while(m>0)
	{
		price=que.top();
		price/=2;
		m--;
		que.pop();
		que.push(price);
	}
	while(!que.empty())
	{
	   sum+=que.top();
	   que.pop();
	}
	printf("%lld\n",sum);
}

猜你喜欢

转载自blog.csdn.net/weixin_42921101/article/details/104389993