HDOJ1892 See you~ #二维树状数组#

See you~

Time Limit: 5000/3000 MS (Java/Others)    Memory Limit: 65535/32768 K (Java/Others)
Total Submission(s): 7839    Accepted Submission(s): 2420

Problem Description

Now I am leaving hust acm. In the past two and half years, I learned so many knowledge about Algorithm and Programming, and I met so many good friends. I want to say sorry to Mr, Yin, I must leave now ~~>.<~~. I am very sorry, we could not advanced to the World Finals last year.
When coming into our training room, a lot of books are in my eyes. And every time the books are moving from one place to another one. Now give you the position of the books at the early of the day. And the moving information of the books the day, your work is to tell me how many books are stayed in some rectangles.
To make the problem easier, we divide the room into different grids and a book can only stayed in one grid. The length and the width of the room are less than 1000. I can move one book from one position to another position, take away one book from a position or bring in one book and put it on one position.

Input

In the first line of the input file there is an Integer T(1<=T<=10), which means the number of test cases in the input file. Then N test cases are followed.
For each test case, in the first line there is an Integer Q(1<Q<=100,000), means the queries of the case. Then followed by Q queries.
There are 4 kind of queries, sum, add, delete and move.
For example:
S x1 y1 x2 y2 means you should tell me the total books of the rectangle used (x1,y1)-(x2,y2) as the diagonal, including the two points.
A x1 y1 n1 means I put n1 books on the position (x1,y1)
D x1 y1 n1 means I move away n1 books on the position (x1,y1), if less than n1 books at that position, move away all of them.
M x1 y1 x2 y2 n1 means you move n1 books from (x1,y1) to (x2,y2), if less than n1 books at that position, move away all of them.
Make sure that at first, there is one book on every grid and 0<=x1,y1,x2,y2<=1000,1<=n1<=100.

Output

At the beginning of each case, output "Case X:" where X is the index of the test case, then followed by the "S" queries.
For each "S" query, just print out the total number of books in that area.

Sample Input

2 3 S 1 1 1 1 A 1 1 2 S 1 1 1 1 3 S 1 1 1 1 A 1 1 2 S 1 1 1 2

Sample Output

Case 1: 1 3 Case 2: 1 4

Author

Sempr|CrazyBird|hust07p43

Source

HDU 2008-4 Programming Contest

Recommend

lcy

Solution

#include <bits/stdc++.h>
using namespace std;

typedef long long ll;
typedef pair<int, int> p;
const double pi = acos(-1.0);
const int inf = 0x3f3f3f3f;
const int maxn = 1e3 + 10;
int c[maxn][maxn];

template<typename T = int>
inline const T read() {
    T x = 0, f = 1; char ch = getchar();
    while (ch < '0' || ch > '9') { if (ch == '-') f = -1; ch = getchar(); }
    while (ch >= '0' && ch <= '9') { x = (x << 3) + (x << 1) + ch - '0'; ch = getchar(); }
    return x * f;
}

template<typename T>
inline void write(T x) {
    if (x < 0) { putchar('-'); x = -x; }
    if (x > 9) write(x / 10);
    putchar(x % 10 + '0');
}

inline int lowbit(int x) { return x & -x; }

void update(int x, int y, int v) {
    for (int i = x; i < maxn; i += lowbit(i))
        for (int j = y; j < maxn; j += lowbit(j))
            c[i][j] += v;
}

int getSum(int x, int y) {
    int res = 0;
    for (int i = x; i; i -= lowbit(i))
        for (int j = y; j; j -= lowbit(j))
            res += c[i][j];
    return res;
}

int query(int x1, int y1, int x2, int y2) {
    return getSum(x2, y2) - getSum(x1 - 1, y2) - getSum(x2, y1 - 1) + getSum(x1 - 1, y1 - 1);
}

int main() {
    int cas = 0, t = read();
    int x1, y1, x2, y2, v;
    while (t--) {
        int n = read();
        memset(c, 0, sizeof(c));
        for (int i = 1; i < maxn; i++) {
            for (int j = 1; j < maxn; j++) {
                update(i, j, 1);
            }
        }
        printf("Case %d:\n", ++cas);
        while (n--) {
            char s[2];
            scanf("%s", s);
            if (s[0] == 'A') {
                x1 = read(); y1 = read(); v = read();
                update(x1 + 1, y1 + 1, v);
            }
            else if (s[0] == 'S') {
                x1 = read(); y1 = read(); x2 = read(); y2 = read();
                if (x1 > x2) swap(x1, x2);
                if (y1 > y2) swap(y1, y2);
                write(query(x1 + 1, y1 + 1, x2 + 1, y2 + 1));
                putchar(10);
            }
            else if (s[0] == 'D') {
                x1 = read(); y1 = read(); v = read();
                v = min(v, query(x1 + 1, y1 + 1, x1 + 1, y1 + 1));
                update(x1 + 1, y1 + 1, -v);
            }
            else if (s[0] == 'M') {
                x1 = read(); y1 = read(); x2 = read(); y2 = read(); v = read();
                v = min(v, query(x1 + 1, y1 + 1, x1 + 1, y1 + 1));
                update(x1 + 1, y1 + 1, -v);
                update(x2 + 1, y2 + 1, v);
            }
        }
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/qq_35850147/article/details/104190510