See you~ (hdu1892 二维树状数组)

Now I am leaving hust acm. In the past two and half years, I learned so many knowledge about Algorithm and Programming, and I met so many good friends. I want to say sorry to Mr, Yin, I must leave now ~~>.<~~. I am very sorry, we could not advanced to the World Finals last year.
When coming into our training room, a lot of books are in my eyes. And every time the books are moving from one place to another one. Now give you the position of the books at the early of the day. And the moving information of the books the day, your work is to tell me how many books are stayed in some rectangles.
To make the problem easier, we divide the room into different grids and a book can only stayed in one grid. The length and the width of the room are less than 1000. I can move one book from one position to another position, take away one book from a position or bring in one book and put it on one position.

Input

In the first line of the input file there is an Integer T(1<=T<=10), which means the number of test cases in the input file. Then N test cases are followed.
For each test case, in the first line there is an Integer Q(1<Q<=100,000), means the queries of the case. Then followed by Q queries.
There are 4 kind of queries, sum, add, delete and move.
For example:
S x1 y1 x2 y2 means you should tell me the total books of the rectangle used (x1,y1)-(x2,y2) as the diagonal, including the two points.
A x1 y1 n1 means I put n1 books on the position (x1,y1)
D x1 y1 n1 means I move away n1 books on the position (x1,y1), if less than n1 books at that position, move away all of them.
M x1 y1 x2 y2 n1 means you move n1 books from (x1,y1) to (x2,y2), if less than n1 books at that position, move away all of them.
Make sure that at first, there is one book on every grid and 0<=x1,y1,x2,y2<=1000,1<=n1<=100.

Output

At the beginning of each case, output "Case X:" where X is the index of the test case, then followed by the "S" queries.
For each "S" query, just print out the total number of books in that area.

Sample Input

2
3
S 1 1 1 1
A 1 1 2
S 1 1 1 1
3
S 1 1 1 1
A 1 1 2
S 1 1 1 2

Sample Output

Case 1:
1
3
Case 2:
1
4

题意:把一个房间划分成一个矩阵,其中的每个放个都可以放书,且每个方格初始都有一本书,接下来有四种操作:S x1 y1 x2 y2是询问a[x1][y1]到a[x2][y2]直接有多少本书,A x1 y1 n1意思是向a[x1][y1]中放n1本书,D x1 y1 n1意思是从a[x1][y1]中拿出n1本书,如果不足则全部拿出。M x1 y1 x2 y2 n1意为从a[x1][y1]中拿出n1本书放到a[x2][y2]中,若不足则全部拿出。

这应该是一道比较简单的二维树状数组的题,详细请看代码:

#include<stdio.h>
#include<string.h>
#include<math.h>
#include<stdlib.h>
#include<algorithm>
using namespace std;
const int N=1005;
int a[N][N],c[N][N];
int lowbit(int i)
{
    return i&(-i);
}
void update(int x,int y,int val)
{
    int i=y;
    while(x<=1001)//这里最小要开到1001,因为开始时会将x和y++,这里哇了很久啊!!!
    {
        y=i;
        while(y<=1001)
        {
            c[x][y]+=val;
            y+=lowbit(y);
        }
        x+=lowbit(x);
    }
}
int sum(int x,int y)
{
    int ans=0,i=y;
    while(x>0)
    {
        y=i;
        while(y>0)
        {
            ans+=c[x][y];
            y-=lowbit(y);
        }
        x-=lowbit(x);
    }
    return ans;
}
int main()
{
    char s[2];
    int n,t,k=1,m,x1,x2,y1,y2;
    scanf("%d",&t);
    while(t--)
    {
        memset(a,0,sizeof(a));
        memset(c,0,sizeof(c));
        for(int i=1;i<=1001;i++)//这里也必须到1001,你懂得
        {
            for(int j=1;j<=1001;j++)
            {
                a[i][j]=1;
                update(i,j,1);
            }
        }
        printf("Case %d:\n",k++);
        scanf("%d",&m);
        for(int i=0;i<m;i++)
        {
            scanf("%s",s);
            if(s[0]=='S')
            {
                scanf("%d%d%d%d",&x1,&y1,&x2,&y2);
                x1++,x2++,y1++,y2++;
                if(x1>x2) swap(x1,x2);
                if(y1>y2) swap(y1,y2);
                //二维求得是一个矩阵的和,划一下图就知道为什么要这样写了,用总的减去左边和右边不要的,然后再加上多减的一个矩阵
                printf("%d\n",sum(x2,y2)-sum(x2,y1-1)-sum(x1-1,y2)+sum(x1-1,y1-1));
            }
            else if(s[0]=='A')
            {
                scanf("%d%d%d",&x1,&y1,&n);
                x1++,y1++;
                a[x1][y1]+=n;
                update(x1,y1,n);
            }
            else if(s[0]=='D')
            {
                scanf("%d%d%d",&x1,&y1,&n);
                x1++,y1++;
                if(a[x1][y1]<n) n=a[x1][y1];
                update(x1,y1,-n);
                a[x1][y1]-=n;//
            }
            else
            {
                scanf("%d%d%d%d%d",&x1,&y1,&x2,&y2,&n);
                x1++,y1++,x2++,y2++;
                if(a[x1][y1]<n) n=a[x1][y1];
                update(x1,y1,-n);
                update(x2,y2,n);
                a[x1][y1]-=n;//
                a[x2][y2]+=n;//
            }
        }
    }
}

猜你喜欢

转载自blog.csdn.net/Never__give__up/article/details/81355385