7-9 用天平找小球 (10 分)

三个球A、B、C,大小形状相同且其中有一个球与其他球重量不同。要求找出这个不一样的球。

输入格式:

输入在一行中给出3个正整数,顺序对应球A、B、C的重量。

输出格式:

在一行中输出唯一的那个不一样的球。

输入样例:

1 1 2

输出样例:

C

C++实现如下:

#include <iostream>
#include <stdio.h>
using namespace std;

int main()
{
    int a,b,c;
    cin >>a>>b>>c;
    if(a==b){
        cout <<"C"<<endl;
    }
    else if(a==c) {
        cout <<"B"<<endl;
    }
    else{
        cout <<"A"<<endl;
    }
    return 0;
}
原创文章 84 获赞 34 访问量 6万+

猜你喜欢

转载自blog.csdn.net/qq_42194332/article/details/98484174