7-22 用天平找小球(10 分)

题目:

三个球A、B、C,大小形状相同且其中有一个球与其他球重量不同。要求找出这个不一样的球。

输入格式:

输入在一行中给出3个正整数,顺序对应球A、B、C的重量。

输出格式:

在一行中输出唯一的那个不一样的球。

输入样例:

1 1 2

输出样例:

C

代码:

#include <stdio.h>
int main(){
    int A=-1, B=-1, C=-1;
    scanf("%d%d%d", &A, &B, &C);
    if( (A+B)/2 == A ){
        printf("C\n");
    }
    else if( (A+C)/2 == A ){
        printf("B\n");
    }
    else{
        printf("A\n");
    }

    return 0;
}

猜你喜欢

转载自blog.csdn.net/qq_36913610/article/details/81116097