算法笔记 4.1 PAT A1025

1025 PAT Ranking (25 分)

Programming Ability Test (PAT) is organized by the College of Computer Science and Technology of Zhejiang University. Each test is supposed to run simultaneously in several places, and the ranklists will be merged immediately after the test. Now it is your job to write a program to correctly merge all the ranklists and generate the final rank.

Input Specification:

Each input file contains one test case. For each case, the first line contains a positive number N (≤100), the number of test locations. Then Nranklists follow, each starts with a line containing a positive integer K (≤300), the number of testees, and then K lines containing the registration number (a 13-digit number) and the total score of each testee. All the numbers in a line are separated by a space.

Output Specification:

For each test case, first print in one line the total number of testees. Then print the final ranklist in the following format:

registration_number final_rank location_number local_rank

The locations are numbered from 1 to N. The output must be sorted in nondecreasing order of the final ranks. The testees with the same score must have the same rank, and the output must be sorted in nondecreasing order of their registration numbers.

Sample Input:

2
5
1234567890001 95
1234567890005 100
1234567890003 95
1234567890002 77
1234567890004 85
4
1234567890013 65
1234567890011 25
1234567890014 100
1234567890012 85

Sample Output:

9
1234567890005 1 1 1
1234567890014 1 2 1
1234567890001 3 1 2
1234567890003 3 1 2
1234567890004 5 1 4
1234567890012 5 2 2
1234567890002 7 1 5
1234567890013 8 2 3
1234567890011 9 2 4

坑人,英文题看题有点吃力,开始奖人数限制在300,哪知道每个考场限制300,100个考场人数限制为30000,结构题数组定义太小了,一直段错误。。浪费好多时间

代码:

#include<iostream>
#include<algorithm>
#include<cstring>
using namespace std;

struct student
{
	char sno[15];
	int score;//分数
	int location_num;//考场号
	int local_rank;//考场排名
	//总排名即是排序后的顺序
}stu[30010];//k<=300 是指每个考场小于300 总的是N*K<=100*300

bool cmp(student a,student b){//考场内排序
	if(a.score!=b.score) return a.score>b.score;
	return strcmp(a.sno,b.sno)<0;//c语言字符数组不能直接用< 或者> 那是比较地址大小
}

int main(){
	int N,K,sumNo=0;
	scanf("%d",&N);
	for(int i=1;i<=N;i++){
		scanf("%d",&K);
		sumNo+=K;
		for(int j=sumNo-K;j<sumNo;j++){
			scanf("%s %d",stu[j].sno,&stu[j].score);
			stu[j].location_num=i;
		}
		sort(stu+sumNo-K,stu+sumNo,cmp);
		int r=1;
		for(int k=sumNo-K;k<sumNo;k++){
			if(k>sumNo-K&&stu[k].score!=stu[k-1].score){
				r=(k-sumNo+K)+1;//与前面一个不相等 排名就是我的序号 前面几个人我就i+1名 同时也更新了r
			}
			stu[k].local_rank=r;
		}
	}
	cout<<sumNo<<endl;
	sort(stu,stu+sumNo,cmp);
	int r=1;
	for(int i=0;i<sumNo;i++){
		if(i>0&&stu[i].score!=stu[i-1].score){
			r=i+1;
		}
		cout<<stu[i].sno<<" "<<r<<" "<<stu[i].location_num<<" "<<stu[i].local_rank<<endl;
	}
	return 0;
}

猜你喜欢

转载自blog.csdn.net/hza419763578/article/details/82933838
今日推荐