POJ-1700-最快渡河(贪心)

Crossing River POJ - 1700

A group of N people wishes to go across a river with only one boat,
which can at most carry two persons. Therefore some sort of shuttle
arrangement must be arranged in order to row the boat back and forth
so that all people may cross. Each person has a different rowing
speed; the speed of a couple is determined by the speed of the slower
one. Your job is to determine a strategy that minimizes the time for
these people to get across.

Input

The first line of the input contains a single integer T (1 <= T <=
20), the number of test cases. Then T cases follow. The first line of
each case contains N, and the second line contains N integers giving
the time for each people to cross the river. Each case is preceded by
a blank line. There won’t be more than 1000 people and nobody takes
more than 100 seconds to cross.

Ouput

For each test case, print a line containing the total number of
seconds required for all the N people to cross the river.

Sample Input

1
4
1 2 5 10

Sample Output

17
//POJ-1700
//贪心--快速渡河
#include <iostream>
#include <algorithm>
using namespace std;

void crossRiver(int n, int speed[]) {
	int ans = 0;//结果
	int left = n;
	while (left > 0) {
		if (n == 1) {
			ans += speed[0];
			break;
		}
		else if (left == 2) {
			ans += speed[1];
			break;
		}
		else if (left == 3) {
			ans += speed[0] + speed[1] + speed[2];
			break;
		}
		else {
			//把最慢的两个送过去,这里有两种策略
			int s1, s2;
			//1.
			s1 = speed[left - 1] + speed[0] + speed[left - 2] + speed[0];
			//2.
			s2 = speed[1] + speed[0] + speed[left - 1] + speed[1];
			ans += min(s1, s2);
			left -= 2;
		}
	}
	cout << ans << endl;
}

int main() {
	int t;
	cin >> t;
	while (t--) {
		int n;
		cin >> n;//n个人数
		int *speed = new int[n];
		for (int i = 0; i < n; i++) {
			cin >> speed[i];
		}
		crossRiver(n, speed);
	}
}
发布了25 篇原创文章 · 获赞 17 · 访问量 719

猜你喜欢

转载自blog.csdn.net/mu_mu_mu_mu_mu/article/details/104540145