PAT 乙级 1042字符统计

题目

请编写程序,找出一段给定文字中出现最频繁的那个英文字母。
输入格式:
输入在一行中给出一个长度不超过 1000 的字符串。字符串由 ASCII 码表中任意可见字符及空格组成,至少包含 1 个英文字母,以回车结束(回车不算在内)。
输出格式:
在一行中输出出现频率最高的那个英文字母及其出现次数,其间以空格分隔。如果有并列,则输出按字母序最小的那个字母。统计时不区分大小写,输出小写字母。
输入样例:

This is a simple TEST. There ARE numbers and other symbols 1&2&3…

输出样例:

e 7

分析

水题

AC代码

#include <iostream>
#include <algorinthm>
#include <vector>
using namespace std;

typedef pair<int, int> pii;

const int N = 1010;

vector<pii> a;

bool cmp (pii m, pii n)
{
 return m.first > n.first || m.first == n.first && m.second < n.second;
}

int main ()
{
    string s;
    getline(cin, s);

    for(int i = 0 ; i < s.size() ; i ++ )
    {
     if(s[i] >= 'a' && s[i] <= 'z' || s[i] >= 'A' && s[i] <= 'Z')
     {
      for(int j = 0 ; j < a.size() ; j ++ )
      {
          if(tolower(s[i]) == a[j].second) a[j].first ++ ;
      }
      a.push_back({1, tolower(s[i])});
     }
    }

    sort(a.begin(), a.end(), cmp);
  
    cout<<a[0].second<<" "<<a[0].first<<endl;

    return 0;
}
发布了52 篇原创文章 · 获赞 22 · 访问量 1732

猜你喜欢

转载自blog.csdn.net/qq_45792080/article/details/104474818
今日推荐