PAT乙级 ——字符串A+B

题目描述
给定两个字符串 A 和 B,本题要求你输出 A+B,即两个字符串的并集。

要求先输出 A,再输出 B,但重复的字符必须被剔除。

输入格式
输入在两行中分别给出 A 和 B,均为长度不超过 10​6​​ 的、由可见 ASCII 字符和空格组成的、由回车标识结束的非空字符串。

输出格式
在一行中输出题面要求的 A 和 B 的和。

输入样例
This is a sample test
to show you_How it works

输出样例
This ampletowyu_Hrk


题解:

#include <iostream>
using namespace std;

string s, a, b;
bool used[150];

int main()
{
    
    
	getline(cin, a);
	getline(cin, b);
	
	s = a + b;		
	for (int i = 0; i < s.size(); i ++)
		if(!used[s[i]])
		{
    
    
			cout << s[i];
			used[s[i]] = true;
		}	
		
	return 0;	
}

猜你喜欢

转载自blog.csdn.net/weixin_46239370/article/details/113867784