UVA108 Maximum Sum【最大子段和+DP】

A problem that is simple to solve in one dimension is often much more difficult to solve in more than one dimension. Consider satisfying a boolean expression in conjunctive normal form in which each conjunct consists of exactly 3 disjuncts. This problem (3-SAT) is NP-complete. The problem 2-SAT is solved quite efficiently, however. In contrast, some problems belong to the same complexity class regardless of the dimensionality of the problem.
    Given a 2-dimensional array of positive and negative integers, find the sub-rectangle with the largest sum. The sum of a rectangle is the sum of all the elements in that rectangle. In this problem the subrectangle with the largest sum is referred to as the maximal sub-rectangle.
    A sub-rectangle is any contiguous sub-array of size 1 × 1 or greater located within the whole array. As an example, the maximal sub-rectangle of the array:
0 −2 −7 0
9 2 −6 2
−4 1 −4 1
−1 8 0 −2
is in the lower-left-hand corner:
9 2
−4 1
−1 8
and has the sum of 15.
Input
The input consists of an N × N array of integers.
    The input begins with a single positive integer N on a line by itself indicating the size of the square two dimensional array. This is followed by N2 integers separated by white-space (newlines and spaces). These N2 integers make up the array in row-major order (i.e., all numbers on the first row, left-to-right, then all numbers on the second row, left-to-right, etc.). N may be as large as 100. The numbers in the array will be in the range [−127, 127].
Output
The output is the sum of the maximal sub-rectangle.
Sample Input
4
0 -2 -7 0 9 2 -6 2
-4 1 -4 1 -1
8 0 -2
Sample Output
15

问题链接UVA108 Maximum Sum
问题简述:(略)
问题分析
    这个题跟与参考链接的题应该是同一个题。
    给代码不解释。
程序说明:(略)
参考链接UVALive2288 POJ1050 HDU1081 ZOJ1074 To The Max【最大子段和+DP】
题记:(略)

AC的C++语言程序如下:

/* UVA108 Maximum Sum */

#include <bits/stdc++.h>

using namespace std;

const int N = 100;
int a[N + 1][N + 1], sum[N + 1][N + 1];

int main()
{
    int n;
    while(~scanf("%d", &n)) {
        for (int i = 0; i <= n; i++)
            sum[i][0] = sum[0][i] = 0;

        for(int i = 1; i <= n; i++)
            for(int j = 1; j <= n; j++) {
                scanf("%d", &a[i][j]);
                sum[i][j] = sum[i - 1][j] + sum[i][j - 1] - sum[i - 1][j - 1] + a[i][j];
            }

        int ans = a[1][1];
        for(int i = 1; i <= n; i++)
            for(int j = i; j <= n; j++) {
                int sum2 = 0, maxSum = INT_MIN, minSum = 0;
                for(int k = 1; k < n; k++) {
                    sum2 += sum[j][k] - sum[j][k-1] - sum[i-1][k] + sum[i-1][k-1];
                    maxSum = max(maxSum, sum2 - minSum);
                    minSum = min(minSum, sum2);
                }
                ans = max(ans, maxSum);
            }

        printf("%d\n", ans);
    }

    return 0;
}

AC的C++语言程序如下:

/* UVA108 Maximum Sum */
 
#include <bits/stdc++.h>
 
using namespace std;
 
const int N = 100;
int a[N + 2][N + 2], sum[N + 2][N + 2];
 
int main()
{
    int n;
    while(~scanf("%d", &n)) {
        memset(a, 0, sizeof(a));
        memset(sum, 0, sizeof(sum));
 
        for(int i = 1; i <= n; i++)
            for(int j = 1; j <= n; j++) {
                scanf("%d", &a[i][j]);
                sum[i][j] = sum[i - 1][j] + sum[i][j - 1] - sum[i - 1][j - 1] + a[i][j];
            }
 
        int maxsum = INT_MIN;
        for(int i = 1; i <= n; i++)
            for(int j = 0; j < i; j++) {
                int t, min = 0;
                for(int k=1; k<=n; k++) {
                    t = sum[i][k] - sum[j][k] - min;
                    if(t>maxsum)
                        maxsum = t;
                    if(sum[i][k] - sum[j][k] < min)
                        min = sum[i][k] - sum[j][k];
                }
            }
 
        printf("%d\n", maxsum);
    }
 
    return 0;
}
发布了2289 篇原创文章 · 获赞 2373 · 访问量 265万+

猜你喜欢

转载自blog.csdn.net/tigerisland45/article/details/105409247
今日推荐