最大乘积(Maximum Product, UVa 11059)

m D - Maximum Product

Time Limit: 1 second

Given a sequence of integers S = {S1, S2, ..., Sn}, you should determine what is the value of the maximum positive product involving consecutive terms of S. If you cannot find a positive sequence, you should consider 0 as the value of the maximum product.

Input

Each test case starts with 1 ≤ N ≤ 18, the number of elements in a sequence. Each element Si is an integer such that -10 ≤ Si ≤ 10. Next line will have N integers, representing the value of each element in the sequence. There is a blank line after each test case. The input is terminated by end of file (EOF).

Output

For each test case you must print the message: Case #M: The maximum product is P., where M is the number of the test case, starting from 1, and P is the value of the maximum product. After each test case you must print a blank line.

Sample Input

3
2 4 -3

5
2 5 -1 2 -1

Sample Output

Case #1: The maximum product is 8.

Case #2: The maximum product is 20.

题目大意:

输入n个元素组成的序列S,你需要找出一个乘积最大的连续子序列。如果这个最大的乘积不是正数,应输出0(表示无解)。1<=n<=18,-10<=Si<=10。

解析:水题一道,直接枚举起点和终点,求最大乘积。注意要用long long

#include <iostream>
#include <cstdio>
using namespace std;
int main()
{
    int n;int d=0;
    while(scanf("%d",&n)!=EOF)
    {
        long long int a[20]= {};
       long long  int ans=0,sum=1;
        int i,j;
        for(i=0; i<n; i++)
            cin>>a[i];
        for(i=0; i<n; i++)
        {
            for(j=i; j<n; j++)
            {
                sum*=a[j];
                   if(ans<sum)
                   ans=sum;
            }
            sum=1;
        }
        d++;
        printf("Case #%d: The maximum product is %lld.\n\n",d,ans);
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/qq_41374539/article/details/81783380
今日推荐