BUY LOW, BUY LOWER POJ - 1952(LIS)(dp)

The advice to “buy low” is half the formula to success in the bovine stock market.To be considered a great investor you must also follow this problems’ advice:
“Buy low; buy lower”

Each time you buy a stock, you must purchase it at a lower price than the previous time you bought it. The more times you buy at a lower price than before, the better! Your goal is to see how many times you can continue purchasing at ever lower prices.

You will be given the daily selling prices of a stock (positive 16-bit integers) over a period of time. You can choose to buy stock on any of the days. Each time you choose to buy, the price must be strictly lower than the previous time you bought stock. Write a program which identifies which days you should buy stock in order to maximize the number of times you buy.

Here is a list of stock prices:
Day 1 2 3 4 5 6 7 8 9 10 11 12

Price 68 69 54 64 68 64 70 67 78 62 98 87

The best investor (by this problem, anyway) can buy at most four times if each purchase is lower then the previous purchase. One four day sequence (there might be others) of acceptable buys is:
Day 2 5 6 10

Price 69 68 64 62
Input
* Line 1: N (1 <= N <= 5000), the number of days for which stock prices are given

  • Lines 2..etc: A series of N space-separated integers, ten per line except the final line which might have fewer integers.
    Output
    Two integers on a single line:
  • The length of the longest sequence of decreasing prices
  • The number of sequences that have this length (guaranteed to fit in 31 bits)

In counting the number of solutions, two potential solutions are considered the same (and would only count as one solution) if they repeat the same string of decreasing prices, that is, if they “look the same” when the successive prices are compared. Thus, two different sequence of “buy” days could produce the same string of decreasing prices and be counted as only a single solution.
Sample Input
12
68 69 54 64 68 64 70 67 78 62
98 87
Sample Output
4 2
思路:这题有个细节,就是选出来的子序列的只管他们的大小不同而不管他们来自哪个坐标,即,选出来的两个子序列如果对应位置上大小一样就当做同一个。
所以在dp即只需要注意一个点。消除同个大小的在先前位置的数量。
代码

#include<iostream>
#include<cstdio>
#include<cmath>
#include<algorithm>
#define INF 0x3f3f3f3f
#include<vector>
#include<set>
using namespace std;
int n;
int a[5005];
int dp[5005];
int num[5005];

int main()
{
    cin>>n;
    for(int i=1;i<=n;i++)
        scanf("%d",a+i);
    for(int i=1;i<=n;i++)
        dp[i]=1,num[i]=1;
    for(int i=2;i<=n;i++)
    {
        for(int j=i-1;j>=1;j--)
        {
            if(a[j]>a[i])
            {
                if(dp[j]+1>dp[i])
                {
                    dp[i]=dp[j]+1;
                    num[i]=num[j];
                }
                else
                    if(dp[j]+1==dp[i])
                        num[i]+=num[j];
            }
            else
                if(a[j]==a[i])
                    num[j]=0;//关键就是这个,因为如果相同,那么这个前面出现的a[j]就不会再转移给其他的状态,因为a[j]比他更优.
        }
    }
    int maxx=1;
    for(int i=1;i<=n;i++)
        maxx=max(maxx,dp[i]);
    int ans=0;
    set<int> sett;
    for(int i=n;i>=1;i--)
        if(dp[i]==maxx)
            ans+=num[i];

    cout<<maxx<<" "<<ans<<endl;
    return 0;
}

猜你喜欢

转载自blog.csdn.net/coldfresh/article/details/80143742
今日推荐