AtCoder - 2567 RGB Sequence

Problem Statement

There are N squares arranged in a row. The squares are numbered 1, 2, , N, from left to right.

Snuke is painting each square in red, green or blue. According to his aesthetic sense, the following M conditions must all be satisfied. The i-th condition is:

  • There are exactly xi different colors among squares li, li+1, , ri.

In how many ways can the squares be painted to satisfy all the conditions? Find the count modulo 109+7.

Constraints
  • 1N300
  • 1M300
  • 1liriN
  • 1xi3
Input

Input is given from Standard Input in the following format:

N M
l1 r1 x1
l2 r2 x2
:
lM rM xM
Output

Print the number of ways to paint the squares to satisfy all the conditions, modulo 109+7.

Sample Input 1
3 1
1 3 3
Sample Output 1
6

The six ways are:

  • RGB
  • RBG
  • GRB
  • GBR
  • BRG
  • BGR

where R, G and B correspond to red, green and blue squares, respectively.

Sample Input 2
4 2
1 3 1
2 4 2
Sample Output 2
6

The six ways are:

  • RRRG
  • RRRB
  • GGGR
  • GGGB
  • BBBR
  • BBBG
Sample Input 3
1 3
1 1 1
1 1 2
1 1 3
Sample Output 3
0

There are zero ways.

Sample Input 4
8 10
2 6 2
5 5 1
3 5 2
4 7 3
4 4 1
2 3 1
7 7 1
1 5 2
1 7 3
3 4 2
Sample Output 4
108



还是小清新dp比较好,写起代码来非常的令人身心愉悦233333
让我们设 f[j][k][u] 为最近出现三种颜色的位置为j,k,u的方案数,那么转移直接把随便一维变成当前枚举的i即可。
至于限制条件,我们只需要在i==r的时候把 (j>=l) + (k>=l) + (u>=l) != x 的 f[j][k][u] 设置成0即可。

看起来是O(N^4)的??? 实际上因为至少一维要是i-1或者i,所以复杂度实际上是O(N^3)的。

#include<cstdio>
#include<vector>
#define ll long long
using namespace std;
#define pb push_back
const int ha=1e9+7,maxn=305;
inline void ADD(int &x,int y){ x+=y; if(x>=ha) x-=ha;}
int f[maxn][maxn][maxn],n,m,k,L,R,ans;
vector<int> g[maxn][4];

inline void update(int p){
	for(int i=1;i<=3;i++)
	    for(int j=g[p][i].size()-1,l;j>=0;j--){
	    	l=g[p][i][j];
	    	
	    	for(int a=0;a<=p;a++)
	    	    for(int b=0;b<=p;b++)
	    	        for(int c=(a<p&&b<p)?p:0;c<=p;c++)
	    	            if((a>=l)+(b>=l)+(c>=l)!=i) f[a][b][c]=0;
		}
}

inline void dp(){
	f[0][0][0]=1;
	for(int i=1;i<=n;i++){
		for(int j=0;j<i;j++)
		    for(int l=0,now;l<i;l++)
		        for(int u=(j<i-1&&l<i-1)?i-1:0;u<i;u++){
		        	now=f[j][l][u];
		        	ADD(f[i][l][u],now);
		        	ADD(f[j][i][u],now);
		        	ADD(f[j][l][i],now);
				}
		
		update(i);
	}
	
	for(int j=0;j<=n;j++)
	    for(int l=0;l<=n;l++)
	        for(int u=(j<n&&l<n)?n:0;u<=n;u++) ADD(ans,f[j][l][u]);
}

int main(){
	scanf("%d%d",&n,&m);
	for(int i=1;i<=m;i++){
		scanf("%d%d%d",&L,&R,&k);
		g[R][k].pb(L);
	}
	
	dp();
	
	printf("%d\n",ans);
	return 0;
}
 

猜你喜欢

转载自www.cnblogs.com/JYYHH/p/9100803.html
RGB
今日推荐