poj 1562: Oil Deposits(递归深搜)

题目来源:http://poj.org/problem?id=1562

之前在hdoj上写了一个基于vector的深搜点击打开链接,当时是为了和宽搜对比,都用了vector而没有用递归。其实递归的深搜思路更清晰更具有可扩展性,所以在这里又写了一个递归的深搜。

Oil Deposits

Time Limit: 1000MS

Memory Limit: 10000K

Description

The GeoSurvComp geologic survey company isresponsible for detecting underground oil deposits. GeoSurvComp works with onelarge rectangular region of land at a time, and creates a grid that divides theland into numerous square plots. It then analyzes each plot separately, usingsensing equipment to determine whether or not the plot contains oil. A plotcontaining oil is called a pocket. If two pockets are adjacent, then they arepart of the same oil deposit. Oil deposits can be quite large and may contain numerouspockets. Your job is to determine how many different oil deposits are containedin a grid.

Input

Theinput contains one or more grids. Each grid begins with a line containing m andn, the number of rows and columns in the grid, separated by a single space. Ifm = 0 it signals the end of the input; otherwise 1 <= m <= 100 and 1<= n <= 100. Following this are m lines of n characters each (notcounting the end-of-line characters). Each character corresponds to one plot,and is either `*', representing the absence of oil, or `@', representing an oilpocket. 

Output

are adjacent horizontally, vertically, ordiagonally. An oil deposit will not contain more than 100 pockets.

Sample Input

1 1

*

3 5

*@*@*

**@**

*@*@*

1 8

@@****@*

5 5

****@

*@@*@

*@**@

@@@*@

@@**@

0 0

Sample Output

0

1

2

2

-----------------------------------------------------

解题思路

递归深搜

-----------------------------------------------------

代码

 

//Oil Deposits
//Time Limit: 1000MS		Memory Limit: 10000K
//Total Submissions: 20679		Accepted: 10808
//Description
//
//The GeoSurvComp geologic survey company is responsible for detecting underground oil deposits. GeoSurvComp works with one large rectangular region of land at a time, and creates a grid that divides the land into numerous square plots. It then analyzes each plot separately, using sensing equipment to determine whether or not the plot contains oil. A plot containing oil is called a pocket. If two pockets are adjacent, then they are part of the same oil deposit. Oil deposits can be quite large and may contain numerous pockets. Your job is to determine how many different oil deposits are contained in a grid.
//Input
//
//The input contains one or more grids. Each grid begins with a line containing m and n, the number of rows and columns in the grid, separated by a single space. If m = 0 it signals the end of the input; otherwise 1 <= m <= 100 and 1 <= n <= 100. Following this are m lines of n characters each (not counting the end-of-line characters). Each character corresponds to one plot, and is either `*', representing the absence of oil, or `@', representing an oil pocket. 
//
//Output
//
//are adjacent horizontally, vertically, or diagonally. An oil deposit will not contain more than 100 pockets.
//Sample Input
//
//1 1
//*
//3 5
//*@*@*
//**@**
//*@*@*
//1 8
//@@****@*
//5 5 
//****@
//*@@*@
//*@**@
//@@@*@
//@@**@
//0 0
//Sample Output
//
//0
//1
//2
//2

#include<fstream>
#include<iostream>
using namespace std;

const int MAX = 101;

char mat[MAX][MAX];

void search(int i, int j, int m, int n)
{
	mat[i][j] = '$';
	if (i>0 && mat[i-1][j]=='@')
	{
		search(i-1,j,m,n);
	}
	if (j>0 && mat[i][j-1]=='@')
	{
		search(i,j-1,m,n);
	}
	if (i>0 && j>0 && mat[i-1][j-1]=='@')
	{
		search(i-1,j-1,m,n);
	}
	if (i<m-1 && mat[i+1][j]=='@')
	{
		search(i+1,j,m,n);
	}
	if (j<n-1 && mat[i][j+1]=='@')
	{
		search(i,j+1,m,n);
	}
	if (i<m-1 && j<n-1 && mat[i+1][j+1]=='@')
	{
		search(i+1,j+1,m,n);
	}
	if (i>0 && j<n-1 && mat[i-1][j+1]=='@')
	{
		search(i-1,j+1,m,n);
	}
	if (i<m-1 && j>0 && mat[i+1][j-1]=='@')
	{
		search(i+1,j-1,m,n);
	}

}


int main()
{
#ifndef ONLINE_JUDGE
	ifstream fin("poj1562.txt");
	int m,n,i,j,cnt=0;
	while(fin >> m >> n)
	{
		if (m==0)
		{
			break;
		}
		cnt = 0;
		for (i=0; i<m; i++)
		{
			for (j=0; j<n; j++)
			{
				fin >> mat[i][j];
			}
		}
		for (i=0; i<m; i++)
		{
			for (j=0; j<n; j++)
			{
				if (mat[i][j] == '@')
				{
					search(i,j,m,n);
					cnt ++;
				}
			}
		}
		cout << cnt << endl;
	}
#endif
#ifdef ONLINE_JUDGE
	int m,n,i,j,cnt=0;
	while(cin >> m >> n)
	{
		if (m==0)
		{
			break;
		}
		cnt = 0;
		for (i=0; i<m; i++)
		{
			for (j=0; j<n; j++)
			{
				cin >> mat[i][j];
			}
		}
		for (i=0; i<m; i++)
		{
			for (j=0; j<n; j++)
			{
				if (mat[i][j] == '@')
				{
					search(i,j,m,n);
					cnt ++;
				}
			}
		}
		cout << cnt << endl;
	}
#endif // ONLINE_JUDGE
}


猜你喜欢

转载自blog.csdn.net/da_kao_la/article/details/80363813