Oil Deposits(深搜)

Description

The GeoSurvComp geologic survey company is responsible for detecting underground oil deposits. GeoSurvComp works with one large rectangular region of land at a time, and creates a grid that divides the land into numerous square plots. It then analyzes each plot separately, using sensing equipment to determine whether or not the plot contains oil. A plot containing oil is called a pocket. If two pockets are adjacent, then they are part of the same oil deposit. Oil deposits can be quite large and may contain numerous pockets. Your job is to determine how many different oil deposits are contained in a grid.
 

Input

The input file contains one or more grids. Each grid begins with a line containing m and n, the number of rows and columns in the grid, separated by a single space. If m = 0 it signals the end of the input; otherwise 1 <= m <= 100 and 1 <= n <= 100. Following this are m lines of n characters each (not counting the end-of-line characters). Each character corresponds to one plot, and is either `*', representing the absence of oil, or `@', representing an oil pocket.
 

Output

For each grid, output the number of distinct oil deposits. Two different pockets are part of the same oil deposit if they are adjacent horizontally, vertically, or diagonally. An oil deposit will not contain more than 100 pockets.
 

Sample Input

 
    
1 1*3 5*@*@***@***@*@*1 8@@****@*5 5 ****@*@@*@*@**@@@@*@@@**@0 0
 

Sample Output

 
  

0122

 


@表示有油田 *表示没有油田 问搜索的层数共有几层


#include <iostream>
#include<stdio.h>
#include<string.h>
using namespace std;
int vis[105][105];
char mp[105][105];
int a[8]={-1,-1,-1,0,0,1,1,1};             //定义了(x,y)周围的八个点
int b[8]={-1,0,1,-1,1,-1,0,1};
int m,n;
void dfs(int x,int y)
{
    int nx,ny;
    vis[x][y]=1;                             //被搜过的标记为1
    for(int i=0;i<8;i++)
    {
        nx=x+a[i];                       //搜索周边的八个点
        ny=y+b[i];
        if(nx>=0&&nx<m&&ny>=0&&ny<n&&vis[nx][ny]==0&&mp[nx][ny]=='@')        
        {
            dfs(nx,ny);
            mp[nx][ny]=='*';    //这个点遍历过了就要设为*,以后不会再遍历到了   
        }
    }
}
int main()
{
    int i,j,ans;
    while(scanf("%d %d",&m,&n)!=EOF)
    {
        ans=0;
        if(m==0&&n==0)
            break;
        memset(vis,0,sizeof(vis));
        memset(mp,0,sizeof(mp));
        for(i=0;i<m;i++)
              scanf("%s",&mp[i]);        //输入字符串!
        for(i=0;i<m;i++)
            for(j=0;j<n;j++)
                if(mp[i][j]=='@'&&vis[i][j]==0)       
                {
                    dfs(i,j);
                    ans++;
                }
        printf("%d\n",ans);

    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/qq_41700151/article/details/80009469