A Simple Math Problem

Given two positive integers a and b,find suitable X and Y to meet the conditions:
X+Y=a
Least Common Multiple (X, Y) =b
Input
Input includes multiple sets of test data.Each test data occupies one line,including two positive integers a(1≤a≤2104),b(1≤b≤109),and their meanings are shown in the description.Contains most of the 12W test cases.
Output
For each set of input data,output a line of two integers,representing X, Y.If you cannot find such X and Y,output one line of “No Solution”(without quotation).
Sample Input
6 8
798 10780
Sample Output
No Solution
308 490
易知 x
y = lcm * gcd。
设 gcd( x, y ) = n ,x = an ,y = bn ,那么:
A = an + bn = (a+b) * n
B = lcm( x, y) = (an * bn) / n = a * b * n。
根据 A 和 B 就可以求出 gcd了,变相的也就求出了 x*y 。

在这里插入代码片
#include"cstdio"
#include"cmath"
#include"cstring"
#include"iostream"
#include"algorithm"
using namespace std; 
int gcd(int a,int b)
{
	return b==0? a:gcd(b, a%b);
}
int main()
{
	long long a,b,x=0;
	while(~scanf("%lld %lld",&a,&b))
	{
		x=gcd(a,b);
		x*=b;
		if(a*a-4*x<0)
		{
			printf("No Solution\n");
		}
		else
		{
			int n=sqrt(a*a-4*x);
			if(n*n!=a*a-4*x)
			{
				printf("No Solution\n");
			}
			else
			{
				int x,y;
				x = (a-n)/2;
				y = a-x;
				printf("%d %d\n",x,y);
			}
		}
	}
	return 0;
}


发布了76 篇原创文章 · 获赞 1 · 访问量 2768

猜你喜欢

转载自blog.csdn.net/weixin_44824383/article/details/104233980