E - 成绩转换 HDU - 2004

E - 成绩转换 HDU - 2004 

输入一个百分制的成绩t,将其转换成对应的等级,具体转换规则如下: 
90~100为A; 
80~89为B; 
70~79为C; 
60~69为D; 
0~59为E; 

Input

输入数据有多组,每组占一行,由一个整数组成。

Output

对于每组输入数据,输出一行。如果输入数据不在0~100范围内,请输出一行:“Score is error!”。

Sample Input

56
67
100
123

Sample Output

E
D
A
Score is error!

代码示例:

//主要考察case的用法。
#include<stdio.h>
int main(){
	int t;
	while(~scanf("%d",&t)){
		if(t<0||t>100)
	          printf("Score is error!\n");
	    else
		switch(t/10)  {
		case 0:
		case 1:
		case 2:
		case 3:
		case 4:
		case 5:printf("E\n");
		       break;
                case 6:printf("D\n");
		       break;
		case 7:printf("C\n");
		       break;
		case 8:printf("B\n");
		       break;
		case 9:
		case 10:printf("A\n");
		       break;    
		}
	}
 } 
发布了25 篇原创文章 · 获赞 7 · 访问量 1913

猜你喜欢

转载自blog.csdn.net/weixin_43426647/article/details/84679653