2004成绩转换c++

Problem Description
输入一个百分制的成绩t,将其转换成对应的等级,具体转换规则如下:
90~100为A;
80~89为B;
70~79为C;
60~69为D;
0~59为E;
Input
输入数据有多组,每组占一行,由一个整数组成。
Output
对于每组输入数据,输出一行。如果输入数据不在0~100范围内,请输出一行:“Score is error!”。
Sample Input
56
67
100
123
Sample Output
E
D
A
Score is error!

#include<iostream>
#include<iomanip>
using namespace std;
int main() {
	int number;
	while (cin >> number)
	{
		if (number > 100 || number < 0) 
		{
			cout << "Score is error!"<<endl;
		}
		else if (number >= 90) 
		{
			cout << "A" << endl;
		}
		else if (number >= 80)
		{
			cout << "B" << endl;
		}
		else if (number >= 70)
		{
			cout << "C" << endl;
		}
		else if (number >= 60)
		{
			cout << "D" << endl;
		}
		else 
			cout << "E" << endl;
	}
	return 0;
}

猜你喜欢

转载自blog.csdn.net/weixin_41274723/article/details/89499916