(HDU2004 c++) 成绩转换

成绩转换

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 175605 Accepted Submission(s): 76974

Problem Description

输入一个百分制的成绩t,将其转换成对应的等级,具体转换规则如下:
90~100为A;
80~89为B;
70~79为C;
60~69为D;
0~59为E;

Input

输入数据有多组,每组占一行,由一个整数组成。

Output

对于每组输入数据,输出一行。如果输入数据不在0~100范围内,请输出一行:“Score is error!”。

Sample Input

56
67
100
123

Sample Output

E
D
A
Score is error!

#include<iostream>
using namespace std;
int main()
{
    int result;
    while (cin >> result)
    {
        if (result >= 90 && result <= 100)
            cout << "A" << endl;
        else if (result >= 80 && result < 90)
            cout << "B" << endl;
        else if (result >= 70 && result < 80)
            cout << "C" << endl;
        else if (result >= 60 && result < 70)
            cout << "D" << endl;
        else if (result >= 0 && result < 60)
            cout << "E" << endl;
        else
            cout << "Score is error!" << endl;
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/qq_38780240/article/details/81331039