ZOJ3211 Dream City(DP)

题目链接
JAVAMAN is visiting Dream City and he sees a yard of gold coin trees. There are n trees in the yard. Let’s call them tree 1, tree 2 …and tree n. At the first day, each tree i has ai coins on it (i=1, 2, 3…n). Surprisingly, each tree i can grow bi new coins each day if it is not cut down. From the first day, JAVAMAN can choose to cut down one tree each day to get all the coins on it. Since he can stay in the Dream City for at most m days, he can cut down at most m trees in all and if he decides not to cut one day, he cannot cut any trees later. (In other words, he can only cut down trees for consecutive m or less days from the first day!)

Given n, m, ai and bi (i=1, 2, 3…n), calculate the maximum number of gold coins JAVAMAN can get.

Input

There are multiple test cases. The first line of input contains an integer T (T <= 200) indicates the number of test cases. Then T test cases follow.

Each test case contains 3 lines: The first line of each test case contains 2 positive integers n and m (0 < m <= n <= 250) separated by a space. The second line of each test case contains n positive integers separated by a space, indicating ai. (0 < ai <= 100, i=1, 2, 3…n) The third line of each test case also contains n positive integers separated by a space, indicating bi. (0 < bi <= 100, i=1, 2, 3…n)

Output

For each test case, output the result in a single line.

Sample Input

2
2 1
10 10
1 1
2 2
8 10
2 3
Sample Output

10
21
Hints:
Test case 1: JAVAMAN just cut tree 1 to get 10 gold coins at the first day.
Test case 2: JAVAMAN cut tree 1 at the first day and tree 2 at the second day to get 8 + 10 + 3 = 21 gold coins in all.
思路:把b【i】比较大的尽量放到后面,dp【i】【j】表示前i棵树第j天的最大价值。

#include<bits/stdc++.h>
using namespace std;
typedef long long ll;
const int maxn=3e2+1;
const int inf=0x3f3f3f3f;
int dp[maxn][maxn];
pair<int,int>p[maxn];
bool cmp(const pair<int,int>&a,const pair<int,int>&b)
{
	return a.second==b.second?a.first<b.first:a.second<b.second;
}
int main()
{
	int T,n,m;
	scanf("%d",&T);
	while(T--)
	{
		scanf("%d %d",&n,&m);
		for(int i=1;i<=n;++i) scanf("%d",&p[i].first);
		for(int i=1;i<=n;++i) scanf("%d",&p[i].second);
		sort(p+1,p+1+n,cmp); 
		memset(dp,0,sizeof(dp));
		for(int i=1;i<=n;++i)
		for(int j=1;j<=m;++j)
		dp[i][j]=max(dp[i-1][j],dp[i-1][j-1]+p[i].first+p[i].second*(j-1));
		printf("%d\n",dp[n][m]);
	}
 } 
发布了328 篇原创文章 · 获赞 1 · 访问量 9103

猜你喜欢

转载自blog.csdn.net/qq_42479630/article/details/105209245
今日推荐