POJ——2411 Mondriaan's Dream (状压 dp)

Squares and rectangles fascinated the famous Dutch painter Piet Mondriaan. One night, after producing the drawings in his 'toilet series' (where he had to use his toilet paper to draw on, for all of his paper was filled with squares and rectangles), he dreamt of filling a large rectangle with small rectangles of width 2 and height 1 in varying ways. 


Expert as he was in this material, he saw at a glance that he'll need a computer to calculate the number of ways to fill the large rectangle whose dimensions were integer values, as well. Help him, so that his dream won't turn into a nightmare!

Input

The input contains several test cases. Each test case is made up of two integer numbers: the height h and the width w of the large rectangle. Input is terminated by h=w=0. Otherwise, 1<=h,w<=11.

Output

For each test case, output the number of different ways the given rectangle can be filled with small rectangles of size 2 times 1. Assume the given large rectangle is oriented, i.e. count symmetrical tilings multiple times.

Sample Input

1 2
1 3
1 4
2 2
2 3
2 4
2 11
4 11
0 0

Sample Output

1
0
1
2
3
5
144
51205

此题题解可以作为模板!!!!打表找规律!!!作为菜鸡的我还不是很懂状压dp~~~

题意:有一个h行w列的大矩形,你可以在里放1*2的长方形,长方形之间互相不重叠,问放满整个大矩形有多少种方案数。

题解:状压dp,看到数据小于20的一般就是状压dp;上代码:

#include <iostream>
#include <cstring>
using namespace std;
const int MAX = 12;
typedef long long ll;
int n,m,tot;//n是行,m是列
ll f[MAX][1<<MAX];
bool check(int state){
	for (int i = 0; i < m;i++){
		if(state&(1<<i)){
			if(!(state&(1<<i+1)))return 0;
			i++;
		}
	}
	return 1;
}
int main(){
	while(cin >> n >> m,n+m){
		if((n*m)&1){
			cout << 0 << endl;
			continue;
		}
		memset(f,0,sizeof(f));
		if(n<m) swap(n,m);
		tot=(1<<m)-1;
		for (int i = 0; i <= tot;i++) if(check(i)) f[1][i]=1;
		for (int i = 2; i <= n;i++){
			for (int j = 0; j <= tot;j++){
				for (int k = 0; k <= tot;k++){
					if((tot^j)&(tot^k)) continue;
					if(!check(((tot^k)&j)^j)) continue;
					f[i][j]+=f[i-1][k];
				}
			}
		}
		cout << f[n][tot] << endl;
	}
	return 0;
}

猜你喜欢

转载自blog.csdn.net/lgz0921/article/details/84790536