PTA 7-9 List Leaves(二叉树)

题目链接:点击打开链接

7-9 List Leaves(25 分)

Given a tree, you are supposed to list all the leaves in the order of top down, and left to right.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (10) which is the total number of nodes in the tree -- and hence the nodes are numbered from 0 to N1. Then N lines follow, each corresponds to a node, and gives the indices of the left and right children of the node. If the child does not exist, a "-" will be put at the position. Any pair of children are separated by a space.

Output Specification:

For each test case, print in one line all the leaves' indices in the order of top down, and left to right. There must be exactly one space between any adjacent numbers, and no extra space at the end of the line.

Sample Input:

8
1 -
- -
0 -
2 7
- -
- -
5 -
4 6

Sample Output:

4 1 5

先根据输入写出对应节点的父节点,和左右子树,然后找出根节点(默认高度为0,左右宽度为0),从上到下遍历一下,得出每个节点的高度(父节点的高度加一)和左右宽度(左子树为父节点宽度减一,右子树为父节点宽度加一),遍历时若存在左右子树,继续遍历,没有左右节点的即为叶子,将叶子的高度,宽度,叶子序号保存在一个结构体里面,排一下序即可。

#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
struct node{
	int pp,tt,ll;
}num[15];
bool cmp(node a,node b)
{
	if(a.tt==b.tt)
	return a.ll<b.ll;
	return a.tt<b.tt;
}
int s=0;
int pre[15],ld[15],rd[15];
int t[15],l[15];
void dfs(int u)
{
	if(ld[u]==-1&&rd[u]==-1)//叶子节点
	{
		num[s].pp=u;
		num[s].tt=t[u];
		num[s++].ll=l[u];
		return ;
	 } 
	if(ld[u]!=-1)//存在左子树 
	{
		 l[ld[u]]=l[u]-1;//u的左右子树左右位置 
		 t[ld[u]]=t[u]+1;//u的左右孩子的上下位置 
		 dfs(ld[u]);
	 } 
    if(rd[u]!=-1)//存在右子树 
    {
    	l[rd[u]]=l[u]+1;
    	t[rd[u]]=t[u]+1; 
    	dfs(rd[u]);
	}	 
}

int main()
{
	int n,i,u;
	char st[10];
	scanf("%d",&n);
	for(i=0;i<n;i++)
	{
		pre[i]=i;
		ld[i]=rd[i]=-1; 
	}
	getchar();
	for(i=0;i<n;i++)
	{
		gets(st);
		if(st[0]>='0'&&st[0]<='9')
		{
			
			u=st[0]-'0';
			pre[u]=i;
			ld[i]=u;
		}
		if(st[2]>='0'&&st[2]<='9')
		{
			u=st[2]-'0';
			pre[u]=i;
			rd[i]=u;
		}
	}
	for(i=0;i<n;i++)
	{
		if(pre[i]==i)//为根 
		{
			t[i]=0;//高度为0
			l[i]=0;//左右为0 
			break; 
		}
	}
	dfs(i);
	sort(num,num+s,cmp);
	printf("%d",num[0].pp);
	for(i=1;i<s;i++)
	printf(" %d",num[i].pp);
	printf("\n");
	return 0;
	
 } 

猜你喜欢

转载自blog.csdn.net/z2664836046/article/details/79672722