Highways(最小生成树)

The island nation of Flatopia is perfectly flat. Unfortunately, Flatopia has no public highways. So the traffic is difficult in Flatopia. The Flatopian government is aware of this problem. They’re planning to build some highways so that it will be possible to drive between any pair of towns without leaving the highway system.
latopian towns are numbered from 1 to N. Each highway connects exactly two towns. All highways follow straight lines. All highways can be used in both directions. Highways can freely cross each other, but a driver can only switch between highways at a town that is located at the end of both highways. he Flatopian government wants to minimize the length of the longest highway to be built. However, they want to guarantee that every town is highway-reachable from every other town.
Input
The first line of input is an integer T, which tells how many test cases followed
The first line of each case is an integer N (3 <= N <= 500), which is the number of villages. Then come N lines, the i-th of which contains N integers, and the j-th of these N integers is the distance (the distance should be an integer within [1, 65536]) between village i and village j. There is an empty line after each test case.
Output

For each test case, you should output a line contains an integer, which is the length of the longest road to be built such that all the villages are connected, and this value is minimum.
Sample Input1

3
0 990 692
990 0 179
692 179 0
Sample Output
692
题意:一个国家要修公路,联通各个地方,问在最短路中最长边的长度。
思路:prim算法求最小生成树。

#include<iostream>
#include<cstdio>
#include<cstring>
using namespace std;
const int inf=1000000000;
int n;
int map[550][550];
int dis[550];
int vis[550];
void prim()
{
    int sum=0;
    for(int i=1; i<=n; i++)
    {
        dis[i]=map[1][i];
        vis[i]=0;
    }
    vis[1]=1;
    dis[1]=inf;
    int biao;
    for(int i=2; i<=n; i++)
    {
        biao=1;
        for(int j=2; j<=n; j++)
        {
            if((!vis[j])&&dis[j]<dis[biao])
            {
                biao=j;
            }
        }
        vis[biao]=1;
        for(int j=1; j<=n; j++)
        {
            if(!vis[j]&&dis[j]>map[j][biao])
                dis[j]=map[j][biao];
        }
    }
    for(int i=2; i<=n; i++)
        if(dis[i]>sum)
            sum=dis[i];
    cout<<sum<<endl;
}
int main()
{
    int t;
    cin>>t;
    while(t--)
    {
        cin>>n;
        for(int i=1; i<=n; i++)
            for(int j=1; j<=n; j++)
                cin>>map[i][j];
        prim();
    }
    return 0;
}
发布了12 篇原创文章 · 获赞 1 · 访问量 191

猜你喜欢

转载自blog.csdn.net/csx_zzh/article/details/105129260