POJ-Highways(最小生成树)

Highways

The island nation of Flatopia is perfectly flat. Unfortunately, Flatopia has a very poor system of public highways. The Flatopian government is aware of this problem and has already constructed a number of highways connecting some of the most important towns. However, there are still some towns that you can't reach via a highway. It is necessary to build more highways so that it will be possible to drive between any pair of towns without leaving the highway system.

Flatopian towns are numbered from 1 to N and town i has a position given by the Cartesian coordinates (xi, yi). Each highway connects exaclty two towns. All highways (both the original ones and the ones that are to be built) follow straight lines, and thus their length is equal to Cartesian distance between towns. All highways can be used in both directions. Highways can freely cross each other, but a driver can only switch between highways at a town that is located at the end of both highways.

The Flatopian government wants to minimize the cost of building new highways. However, they want to guarantee that every town is highway-reachable from every other town. Since Flatopia is so flat, the cost of a highway is always proportional to its length. Thus, the least expensive highway system will be the one that minimizes the total highways length.

Input

The input consists of two parts. The first part describes all towns in the country, and the second part describes all of the highways that have already been built.

The first line of the input file contains a single integer N (1 <= N <= 750), representing the number of towns. The next N lines each contain two integers, xi and yi separated by a space. These values give the coordinates of i th town (for i from 1 to N). Coordinates will have an absolute value no greater than 10000. Every town has a unique location.

The next line contains a single integer M (0 <= M <= 1000), representing the number of existing highways. The next M lines each contain a pair of integers separated by a space. These two integers give a pair of town numbers which are already connected by a highway. Each pair of towns is connected by at most one highway.

Output

Write to the output a single line for each new highway that should be built in order to connect all towns with minimal possible total length of new highways. Each highway should be presented by printing town numbers that this highway connects, separated by a space.

If no new highways need to be built (all towns are already connected), then the output file should be created but it should be empty.

Sample Input

9
1 5
0 0 
3 2
4 5
5 1
0 4
5 2
1 2
5 3
3
1 3
9 7
1 2

Sample Output

1 6
3 7
4 9
5 7
8 3

题目链接:

http://poj.org/problem?id=1751

题意描述:

给你n个坐标点,两两之间的距离就是这两点之间的权值,然后给你一个m,接下来m行代表这两点已经连接,求把所有的点相连的最小生成树。

解题思路:

把所有的点两两之间的权值存到一个数组里,只把该矩阵的上三角存到数组里即可(把整个矩阵都存起来数据太多会超时),接下来用克鲁斯卡尔算法每加入一条边就输出一次。

程序代码:

#include<stdio.h>
#include<string.h>
#include<math.h>
#include<algorithm>
using namespace std;
#define inf 99999999
struct data{
	int u;
	int v;
	double w;
}e[1000010];
 
int a[1010],b[1010],f[1010];
 
int cmp(data a,data b);
int getf(int u);
int merge(int u,int v);
 
int main()
{
	int n,i,j,k,t,m,p,q;
	while(scanf("%d",&n)!=EOF)
	{
		for(i=1;i<=n;i++)
			scanf("%d%d",&a[i],&b[i]);
		t=1;
		for(i=1;i<=n;i++)
			for(j=i+1;j<=n;j++)
			{
				e[t].u=i;
				e[t].v=j;
				e[t++].w=(double)sqrt((a[i]-a[j])*(a[i]-a[j])*1.0+(b[i]-b[j])*(b[i]-b[j])*1.0);
			}
		sort(e+1,e+t,cmp);
		for(i=1;i<=n;i++)
			f[i]=i;
		scanf("%d",&m);	
		for(i=1;i<=m;i++)
		{
			scanf("%d%d",&p,&q);
			if(getf(p)!=getf(q))
				f[getf(q)]=getf(p);
		}
		for(i=1;i<t;i++)
		{
			if(merge(e[i].u,e[i].v)==1)
				printf("%d %d\n",e[i].u,e[i].v);
		}	
	}
	return 0;	
} 
 
int cmp(data a,data b)
{
	return a.w<b.w;
}
 
int getf(int u)
{
	if(u==f[u])
		return u;
	f[u]=getf(f[u]);
	return f[u];
}
 
int merge(int u,int v)
{
	u=getf(u);
	v=getf(v);
	if(u!=v)
	{
		f[v]=u;
		return 1;
	}
	return 0;
}

猜你喜欢

转载自blog.csdn.net/HeZhiYing_/article/details/84145157