Message Decowding HDU - 2716

Message Decowding

  HDU - 2716

The cows are thrilled because they've just learned about encrypting messages. They think they will be able to use secret messages to plot meetings with cows on other farms. 

Cows are not known for their intelligence. Their encryption method is nothing like DES or BlowFish or any of those really good secret coding methods. No, they are using a simple substitution cipher. 

The cows have a decryption key and a secret message. Help them decode it. The key looks like this: 

yrwhsoujgcxqbativndfezmlpk 


Which means that an 'a' in the secret message really means 'y'; a 'b' in the secret message really means 'r'; a 'c' decrypts to 'w'; and so on. Blanks are not encrypted; they are simply kept in place. 

Input text is in upper or lower case, both decrypt using the same decryption key, keeping the appropriate case, of course.
Input* Line 1: 26 lower case characters representing the decryption key 

* Line 2: As many as 80 characters that are the message to be decodedOutput* Line 1: A single line that is the decoded message. It should have the same length as the second line of input.Sample Input
eydbkmiqugjxlvtzpnwohracsf
Kifq oua zarxa suar bti yaagrj fa xtfgrj
Sample Output
Jump the fence when you seeing me coming

题解:

#include<cstdio>
#include<cstring>
#include<cstdlib>
#include<algorithm>
#include<iostream>
char rep[30];
int main()
{
    scanf("%s", rep);
    getchar();
    while(1)
    {
        char temp;
        temp = getchar();
        if(temp == '\n')
        {
            printf("\n");
            break;
        }
        else
        {
            if(temp == ' ')
            {
                printf(" ");
            }
            else
            {
                if(temp<='Z')
                {
                    int x = temp - 'A';

                    printf("%c", rep[x] - 32);
                }
                else
                {
                    int x = temp - 'a';
                    printf("%c", rep[x]);
                }
            }
        }
    }

    return 0;
}


猜你喜欢

转载自blog.csdn.net/qq_40758751/article/details/80290871