hdu1509 Windows Message Queue

Windows Message Queue

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 8879    Accepted Submission(s): 3654


 

Problem Description

Message queue is the basic fundamental of windows system. For each process, the system maintains a message queue. If something happens to this process, such as mouse click, text change, the system will add a message to the queue. Meanwhile, the process will do a loop for getting message from the queue according to the priority value if it is not empty. Note that the less priority value means the higher priority. In this problem, you are asked to simulate the message queue for putting messages to and getting message from the message queue.

 

Input

There's only one test case in the input. Each line is a command, "GET" or "PUT", which means getting message or putting message. If the command is "PUT", there're one string means the message name and two integer means the parameter and priority followed by. There will be at most 60000 command. Note that one message can appear twice or more and if two messages have the same priority, the one comes first will be processed first.(i.e., FIFO for the same priority.) Process to the end-of-file.

 

Output

For each "GET" command, output the command getting from the message queue with the name and parameter in one line. If there's no message in the queue, output "EMPTY QUEUE!". There's no output for "PUT" command.

 

Sample Input

 
GET
PUT msg1 10 5
PUT msg2 10 4
GET
GET
GET
 

Sample Output

 
EMPTY QUEUE!
msg2 10
msg1 10
EMPTY QUEUE!

题意:

即模拟邮件的处理,如果是get就拿出一个邮件,对于拿出的邮件都有一个优先级,优先级越小他就先被拿出来,如果优先级相同则根据他们得到的先后顺序排优先级,先得到就先拿出,很明显这是一道队列的水题;

思路:直接用队列模拟即可

代码:

#include<cstdio>
#include<iostream>
#include<algorithm>
#include<string>
#include<cstring>
#include<stack>
#include<queue>
#include<vector>
#include<map>
#include<set>
#define ll long long
using namespace std;
struct Mes
{
    char name[100];
    int par,fst,num;
//    friend bool operator <(Mes a,Mes b)
//    {
//        if (a.fst == b.fst) return a.num > b.num;
//        return a.fst > b.fst;
//    }
}m;
bool operator <(const Mes &a,const Mes &b)
{
    if (a.fst == b.fst) return a.num > b.num;
    return a.fst > b.fst;
}
int main()
{
    int i = 0;
    char str[100];
    priority_queue<Mes> q;
    while (~scanf("%s",str))
    {

        i ++;
        if (str[0] == 'G')
            if (!q.empty())
            {
                Mes M = q.top();
                printf("%s %d\n",M.name,M.par);
                
                q.pop();
            }
            else printf("EMPTY QUEUE!\n");
        else
        {
            scanf("%s %d %d",m.name,&m.par,&m.fst);m.num = i;
            q.push(m); 
        }
    }
    return 0;

猜你喜欢

转载自blog.csdn.net/cloudy_happy/article/details/81254809